Test and Measurement Forum

Error: IsMV Failed

Discussion forum for the new Picoscope Linux software

Error: IsMV Failed

Postby b2ag » Thu Mar 03, 2016 8:09 pm

Hi,

I've trouble getting Picoscope to work under Arch Linux.

Usbtest-Tool says everything is fine. PS6000con works fine. Picoscope-Application complains about "Error: IsMV Failed".

Could not paste full logs, because Apache Mod-Security, I guess.

Bye
b2ag
Newbie
 
Posts: 0
Joined: Thu Mar 03, 2016 8:01 pm

Re: Error: IsMV Failed

Postby AndrewA » Tue Mar 08, 2016 9:06 am

Hi,

Could you email your log files into support@picotech.com.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: Error: IsMV Failed

Postby mattvenn » Sat Mar 26, 2016 5:28 pm

I've got the same error message on ubuntu 14 with the latest version of picoscope.
usbtest and ps3000acon both work but picoscope doesn't ever detect.
mattvenn
Newbie
 
Posts: 0
Joined: Sat Mar 26, 2016 5:27 pm

Re: Error: IsMV Failed

Postby Martyn » Mon Apr 04, 2016 2:31 pm

Have you got any error logs that you can post ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2352
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Error: IsMV Failed

Postby mario_ » Tue Apr 05, 2016 12:13 pm

Actually the error is most commonly associated with mono version. Versions 4.2.1 and newer carry piece of the code that breaks Picoscope 6 for Linux. The fix has been supplied to Mac version, Linux version will get it in the next release. In the meantime I can only advise to use older versions of mono, like 3.2.8.
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Re: Error: IsMV Failed

Postby mattvenn » Thu Apr 07, 2016 12:10 pm

Thanks Mario and Martyn.
Is there any info on running an older version of mono on an ubuntu system? I don't think I can downgrade it easily (too many dependencies) so I'd need to install it somewhere else.
mattvenn
Newbie
 
Posts: 0
Joined: Sat Mar 26, 2016 5:27 pm

Re: Error: IsMV Failed

Postby mario_ » Fri Apr 08, 2016 7:57 am

https://software.opensuse.org/download/ ... e=mono-opt

Unfotunately only version for ubuntu12 is 4.0.4, free from this bug. The others are up to date. You could trying using ubuntu12 setup, even if you have different version of this os.

There is alternative with mono 3.12: https://software.opensuse.org/download. ... e=mono-opt
This one does not provide gtksharp-2 and mono-basic. Would require more fiddle.

Picoscope6 package requires normal mono to be installed. Mono-opt is not replacement, so the the startup script will need changing.

Before the lines of (around line 20):

Code: Select all
CLI_CMD=$(which cli 2>/dev/null)
MONO_CMD=$(which mono 2>/dev/null)

Add suited to your installation entries, to look like (in case of mono-opt):

Code: Select all
export PATH="/opt/mono/bin:$PATH"
export LD_LIBRARY_PATH="/opt/mono/lib:$LD_LIBRARY_PATH"
CLI_CMD=$(which cli 2>/dev/null)
MONO_CMD=$(which mono 2>/dev/null)


You can try and compile you own version of mono, but it may create greater sea of problems. If you still think of doing it prepare your system to have all bits required for it:
Code: Select all
sudo apt-get build-dep mono-runtime mono-basic gtk-sharp2

Download yourself a sources of mono, mono-basic and gtk-sharp2. They may require associated patches to compile at all - check the folders they are coming from. After extracting, first run ./configure --prefix=/path/to/where/it/goes for mono, then make and sudo make install. Next one is mono-basic: again ./configure --prefix=/path/as/before , then make and sudo make install. Finally gtk sharp, ./configure --prefix=/path/as/before RUNTIME=/path/as/before CSC=/path/as/before/bin/mcs PKG_CONFIG_PATH=/path/as/before/lib/pkgconfig , then make and sudo make install.

Or... just wait for the next picoscope release.

Mario
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Re: Error: IsMV Failed

Postby mcComBat » Fri Apr 15, 2016 1:09 pm

Hi, I am experiencing the same problem on Arch Linux, and I would prefer not to downgrade the Mono package, because of other software I have that depends on it.

When will the fix be available to the Linux version of PicoScope?

Thanks!
mcComBat
Newbie
 
Posts: 0
Joined: Fri Apr 15, 2016 1:07 pm

Re: Error: IsMV Failed

Postby Martyn » Tue May 10, 2016 1:29 pm

A new version for Linux is currently in final test and will be uploaded to the repository shortly.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2352
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Error: IsMV Failed

Postby OrangeCrush » Thu May 12, 2016 3:47 am

Hey Martyn -

Thanks for the update. Do we know what version of picoscope will have this bugfix? I'm currently seeing the error in my 6.11.8.10 install.
OrangeCrush
Newbie
 
Posts: 0
Joined: Thu May 12, 2016 3:24 am

Re: Error: IsMV Failed

Postby Martyn » Tue May 17, 2016 10:05 am

6.11.13.3 is available from the repository (if it is currently on line, there have been some network issues)
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2352
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Error: IsMV Failed

Postby casamich » Tue May 17, 2016 10:53 am

I had the same problem on Ubuntu 16.04, and confirm that the 6.11.8.13 version works correctly.
My mono version is Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4).
Thank you for the support.
casamich
Newbie
 
Posts: 0
Joined: Tue May 17, 2016 10:49 am


Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests