Test and Measurement Forum

PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Discussion forum for the new Picoscope Linux software

PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby silvan » Mon Dec 21, 2015 10:45 am

Hi there,

There was some update either of the software or the system, now the PS does not find my scope.

maybe unrelated:
Opening in a terminal I get:
Code: Select all
(PicoScope.GTK:14296): GLib-CRITICAL **: Source ID 8 was not found when attempting to remove it

This gets spammed when I let it open a demo device

Scope is visible to the system:
Code: Select all
Bus 003 Device 008: ID 0ce9:de00 pico Technology


cheers, Silvan

here are the details:

Code: Select all
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:        14.04
Codename:       trusty


Code: Select all
3.13.0-74-generi


Code: Select all
Package: libps2000
Status: install ok installed
Priority: extra
Section: libs
Installed-Size: 1009
Maintainer: Pico Support <support@picotech.com>
Architecture: amd64
Version: 2.1.5-3r06
Depends: debconf (>= 0.5) | debconf-2.0, libc6 (>= 2.3.2), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.1.1), libusb-1.0-0 (>= 2:1.0.8)
Description: PicoScope 2000 Linux driver


Code: Select all
Package: picoscope
Status: install ok installed
Priority: optional
Section: electronics
Installed-Size: 19695
Maintainer: Pico Support <support@picotech.com>
Architecture: all
Version: 6.11.8-4r10
Depends: debconf (>= 0.5) | debconf-2.0, mono-runtime (>= 2.10.8.1), libmono-system-core4.0-cil (>= 2.10.8.1), libmono-system-management4.0-cil (>= 2.10.8.1), libmono-system-windows-forms4.0-cil (>= 2.10.8.1), libmono-system-runtime-serialization4.0-cil (>= 2.10.8.1), libmono-windowsbase4.0-cil (>= 2.10.8.1), libmono-microsoft-visualbasic10.0-cil (>= 2.10), libgtk2.0-cil (>= 2.12.10), libpicoipp (>= 1.1.1-1), libpl1000 (= 1.0.8-1r06), libps2000 (= 2.1.5-3r06), libps2000a (= 1.1.5-5r28), libps3000 (= 3.7.6-3r05), libps3000a (= 1.4.5-6r45), libps4000 (= 1.2.5-2r18), libps4000a (= 1.0.5-2r31), libps5000 (= 1.5.5-3r16), libps5000a (= 1.1.5-5r24), libps6000 (= 1.4.5-6r34), libusbdrdaq (= 1.0.5-1r06)
Description: PicoScope GTK
Homepage: <http://www.picotech.com>


Code: Select all
Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1.1)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen
silvan
Newbie
 
Posts: 0
Joined: Mon Dec 21, 2015 10:29 am

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby AndrewA » Tue Dec 22, 2015 11:36 am

Hi Silvan,

I just tested a PS2204A with Ubuntu 14.04.3 LTS PC (x64), no issues.
Just did a software update.
Same versions of Picoscope, Ubuntu and mono that you listed below.
What scope do you have?
Does it work on another windows PC?
Can you check the USB cable and connections. Try another USB port or use a USB powered hub.
Is of our blue USB cables you are using? Try a different USB cable if you have one.
Let us known if you are still have issues.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby silvan » Thu Dec 24, 2015 3:58 pm

Hi Andrew,

thanks for the fast response!

Currently I have no access to a windows PC.
I have a PicoScope 2204.

I did some more digging and noticed this:
Code: Select all
Device: Info: Attempting to load ps3000.dll
Device: Info: Finished loading ps3000.dll
Device: Info: Opening device using DLL ps3000.dll
Device: Info: Opening device unsuccessful. Error UnitNotFound
Device: Info: Attempting to load ps2000a.dll
Device: Info: Finished loading ps2000a.dll
Device: Info: Opening device using DLL ps2000a.dll
Message: Info: Opening PS2000a.dll
Device: Info: Opening device unsuccessful. Error UnitNotFound
Device: Info: Attempting to load ps2000.dll
Device: Info: Finished loading ps2000.dll
Device: Info: Opening device using DLL ps2000.dll
Device: Info: Opening device unsuccessful. Error UnitNotFound

Message: Info: Opening PS2000a.dll
This looks like it tries to open the 2204 nonA with the A library.

PS: The .dll looks a bit strange on linux ;)
silvan
Newbie
 
Posts: 0
Joined: Mon Dec 21, 2015 10:29 am

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby silvan » Fri Jan 01, 2016 10:26 am

Update:
Tried on a windows PC (with the beta version of the scope software): does not manage to install the driver (says unknown device)
silvan
Newbie
 
Posts: 0
Joined: Mon Dec 21, 2015 10:29 am

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby AndrewA » Mon Jan 04, 2016 3:33 pm

Hi Silvan,

Could I get you to email (support@picotech.com) into helpdesk system to resolve the windows PC issue.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby silvan » Tue Jan 05, 2016 6:53 am

Hi Andrew,

I currently do not own any PC with windows on it. Can you elaborate on how solving the issue under windows will help with my issue under linux?

cheers, Silvan
silvan
Newbie
 
Posts: 0
Joined: Mon Dec 21, 2015 10:29 am

Re: PS 6.11.8.10 does not find scope (Kubuntu 14.04)

Postby AndrewA » Tue Jan 05, 2016 2:03 pm

Hi Silvan,

Just want to confirm the scope is still working, correctly.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm


Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests