Test and Measurement Forum

Trigger for current waveforms TA189

Forum for discussing PicoScope version 6 (non-automotive version)

Trigger for current waveforms TA189

Postby logan54 » Tue Dec 08, 2015 7:37 pm

Hello Forum,

I’am using following components:
PicoScope® 6 - PC-Oszilloskop-Software Version: 6.10.18.1052
Modell: PicoScope 2206A
Seriennummer: CY402/015
USB-Version: 2,0
Kalibrierungsdatum: Dienstag, 25. März 2014
Hardwareversion: 1
Treiberversion: 1.1.4.49
Firmwareversion: 1.3.3.0 / 0.5.29.0

For measuring current Waveforms I’ve connected a TA189 Current clamp on channel B, but I cannot use the automatic Trigger for this channel, each Trigger setting behaves like the "No Trigger" setting.
I’ve attached a waveform showing this problem.
Is there a hint how to use trigger at the current waveform?

Regards,
logan54
Attachments
20151208-0001.psdata
No automatic Triggering on Channel B possible, see trigger point vs. Channel B
(30.94 KiB) Downloaded 36 times
logan54
Newbie
 
Posts: 0
Joined: Fri Apr 03, 2015 7:26 am

Re: Trigger for current waveforms TA189

Postby AndrewA » Wed Dec 09, 2015 3:31 pm

Hi logan54,

The signal has far amount of noise on it. When using a simple edge trigger there is a set level of hysteresis.
If you change from a simple edge to an advanced edge, using the the advanced trigger menu on the bottom tool bar, you can change the amount of hysteresis. Try setting it to 3% to start.
Let us know if this does not solve the issue.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: Trigger for current waveforms TA189

Postby logan54 » Wed Dec 09, 2015 6:26 pm

Hello Andrew,

Thank you for your Answer.
You are right, there is quite Noise on the Signal.
If I use the 8 Bit setting, so the Trigger fires often on a spike. Because of the lack of an input signal filtering on this device, I've set the resolution enhancement of the channel to 10 bit.
It seems to me that the device still triggers at 8 Bit resolution, but the signal averaging to 10 bit is done at the PC side.
Could this be an issue?
Anyhow the Method you described improves triggering.

Thank you for your Advice

regards,
logan54
logan54
Newbie
 
Posts: 0
Joined: Fri Apr 03, 2015 7:26 am


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests