Test and Measurement Forum

PicoScope on Gentoo

Discussion forum for the new Picoscope Linux software

PicoScope on Gentoo

Postby crosswinds » Tue Dec 08, 2015 4:42 pm

Hello.

Ive been a Gentoo user for many years. And Now i also want my picoscope to run on a linuxmachine.
I see that its supported on several different distributions, but i think i can get it to work if i get the RPM files of the software.

Is there anywhere i can fetch that?
crosswinds
Newbie
 
Posts: 0
Joined: Tue Dec 08, 2015 4:39 pm

Re: PicoScope on Gentoo

Postby Drehstromlampe » Wed Dec 09, 2015 10:54 am

https://www.picotech.com/downloads/linux

If you get it running on Gentoo then pls tell me how you did it.
Want to get it running on Arch.
rpmextract failed. Haven't had the time yet to research the error-messages
Drehstromlampe
Newbie
 
Posts: 0
Joined: Mon Dec 07, 2015 11:49 pm

Re: PicoScope on Gentoo

Postby crosswinds » Wed Dec 09, 2015 5:47 pm

Hello!

I actually got it to work on gentoo. It was way more simple than i thought.
However, since i couldnt find what dependencies it needed, i went with trial and error.
i needed the gtk-dotnet-sharp package, and ofcourse mono.

Then i downloaded the latest version of every rpm package found under my arch (i386) Installed that and then it was OK!
Very happy with this.


Though, it seems to me as it "freezes" every three seconds or so. Seems almost like the computer is to slow. But it is just utilizing 20% of the cpu,, Any ideas on that?
crosswinds
Newbie
 
Posts: 0
Joined: Tue Dec 08, 2015 4:39 pm

Re: PicoScope on Gentoo

Postby AndrewA » Thu Dec 10, 2015 12:02 pm

Hi,

If you can send in files I requested via helpdesk or post them here and we will have look at the issue.
It doesn't sound like a linux only issue as its happening on Windows XP.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm


Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests