Test and Measurement Forum

PicoScope 3205DMSO not recognized OSX 10.10.5

Discussion forum for the new Picoscope Mac software

PicoScope 3205DMSO not recognized OSX 10.10.5

Postby miatech » Fri Nov 20, 2015 5:42 pm

Computer: Apple iMac 27 inch late 2013
Computer: Apple MacBook Pro 13 inch mid 2012
OS: OSX 10.10.5
Installed: MonoFramework-MDK-4.2.1.102.macos10.xamarin.universal.pkg
Installed: PicoScope-6.11.8.5.pkg

Using either blue cable (USB2 or 3), PicoScope not recognized by system under System Information/System Report/USB

However,

Works perfectly using blue USB2 cable running VMWare Fusion/Windows7 virtual machine on MacBook Pro.

So - I'm not stuck. But curious why it won't run natively in OSX.
miatech
Newbie
 
Posts: 0
Joined: Fri Nov 20, 2015 5:26 pm

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby miatech » Mon Nov 23, 2015 1:18 pm

Update: There is an entry under "USB 3.0 Hi-Speed Bus" for "Westbridge".
miatech
Newbie
 
Posts: 0
Joined: Fri Nov 20, 2015 5:26 pm

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby mario_ » Mon Nov 23, 2015 2:07 pm

Hi miatech,

We have discovered this few days ago. Newest version of mono (as any above and including 4.0.5, 4.2.1 especially) has introduced feature/bug, which causes issues with communication on the line PicoScope6 <-> drivers. The workaround/fix has been proved to work, now we are looking into preparing another release including those fixes.

In mean time you could try to use older version of mono; 3.12.0 works for me.


Regards,
Mario
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby nikolaus » Mon Nov 23, 2015 3:50 pm

I had the same problem with an unrecognized scope, and installing Mono 3 worked for me.
Thanks!
nikolaus
Newbie
 
Posts: 0
Joined: Mon Nov 23, 2015 3:43 pm

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby miatech » Tue Nov 24, 2015 7:27 pm

Works with Mono 3.12.0 - brilliant!
miatech
Newbie
 
Posts: 0
Joined: Fri Nov 20, 2015 5:26 pm

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby j9k » Mon Nov 30, 2015 10:31 pm

This helped get my scope going. Thanks!
j9k
Newbie
 
Posts: 0
Joined: Sun Mar 16, 2014 7:20 am

Re: PicoScope 3205DMSO not recognized OSX 10.10.5

Postby mario_ » Tue Dec 01, 2015 10:20 am

The fixes for mono have now been included in the new release 6.11.8.11, that just made its way to the website.
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm


Return to PicoScope for Mac

Who is online

Users browsing this forum: No registered users and 0 guests