Test and Measurement Forum

picoscope 6 not seeing picoscope 4262

Having problems ? let us know the details here

picoscope 6 not seeing picoscope 4262

Postby sirej » Thu Oct 22, 2015 1:16 pm


I have a problem when connecting my picoscope 4262 to a windows 7 PC. When i first connect it picoscope 6 dose not see the device but if i manually connect it will work until i close the program. When the program is restarted (PC not rebooted) the program cant find the picoscope. In the printers and devices menu on the PC i can see the picoscope but some times it seems to reconnect (disappears and appears again). The picoscope works perfectly when connecting to my personal windows machine.

As solutions i have tried to reinstall everything i could connect to picoscope (drivers for the 4262 and Picoscope 6) and with different versions of picoscope 6, but havent found any solution to the problem. I have also tried with the same results on an identical computer.

I hope someone have experienced similar problems and can help me.

Posts: 0
Joined: Thu Oct 22, 2015 12:26 pm

Re: picoscope 6 not seeing picoscope 4262

Postby Hitesh » Fri Oct 23, 2015 10:02 am

Hi Simon,

Are you using a desktop or laptop PC and the supplied blue USB cable?

Have you tried different USB ports on the PC? If it is a desktop PC, please try using the rear USB ports if you are using the front?

It might be helpful to see the trace.xml file when the device is not recognised - please ensure that you are using the latest version of the PicoScope 6 software and refer to section 3 of the PicoScope 6 Self-Help Guide.


Technical Specialist
Pico Technology
Site Admin
Site Admin
Posts: 2023
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 1 guest