Test and Measurement Forum

Signal generator switching frequency

Post your LabVIEW discussions here

Signal generator switching frequency

Postby Inverterguru » Thu Oct 15, 2015 10:41 am

Hello,

I want to switch the signal generator frequency. To test it I create the attached VI. If I run the VI there are drops in the signal wave (see attached oscillogram). How I can switch the frequency without these drops?
(I don't want to build a sweeping generator. I create the VI as a sweeping mode only for testing).

Best regards,
Ulrich

LabView 2014
PicoScope 3406D MSO
PicoScope3000a.dll (32bit)
Attachments
Bode.png
VI as Picture
SCR0001.png
Oscillogram
SCR0001.png (2.4 KiB) Viewed 930 times
Bode.vi
Original VI (LabView 2014)
(12.48 KiB) Downloaded 46 times
Inverterguru
Newbie
 
Posts: 0
Joined: Thu Oct 15, 2015 10:13 am

Re: Signal generator switching frequency

Postby AndrewA » Thu Oct 15, 2015 2:27 pm

Hello Ulrich,

I would remove the 100ms delay. You may still find you have a vertical edge in the waveform when changing frequencies.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: Signal generator switching frequency

Postby Inverterguru » Mon Oct 26, 2015 2:44 pm

Hello Andrew,

if I remove the delay the drops come up more. I find out that these is a problem of the firmware, not a problem of LabView or an other language. If I change the frequency with the PicoScope software the same problem occurs.

Thank you for your help.

Best regards,
Ulrich
Inverterguru
Newbie
 
Posts: 0
Joined: Thu Oct 15, 2015 10:13 am

Re: Signal generator switching frequency

Postby AndrewA » Wed Oct 28, 2015 11:32 am

Yes this not avoidable, its just how the hardware of the signal generator works. You could setup a sweep with the signal generator if you want to step through a range of frequencies.
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests