Test and Measurement Forum

Problems with USB ADC-11/12 and too big values

Post general discussions on using our drivers to write your own software here

Problems with USB ADC-11/12 and too big values

Postby Harald Weber » Fri Oct 28, 2005 11:06 am

I write a software to measure 10 channels with USB ADC-11/12. If I measure, I get some values which are too big. The values are 0xFFFF (65535). What does this mean. My code seems to be ok.

Code: Select all
no_of_channels = 10;
channels[0] = 1;
channels[1] = 2;
channels[2] = 3;
channels[3] = 4;
channels[4] = 5;
channels[5] = 6;
channels[6] = 7;
channels[7] = 8;
channels[8] = 9;
channels[9] = 10;
adc11_open_unit(101, 111);
max_adc_value = adc11_max_value();
if (!adc11_is_streaming()){
     return;
}
adc11_set_trigger(false, true, 1000, 0, false, 80, -10);
actual = adc11_set_interval (1000000, 1000, channels, no_of_channels);
adc11_run (10000, BM_STREAM);
while (!adc11_ready ()){
    Sleep (100);
}
while (!Terminated){
     no_of_values = adc11_get_times_and_values (times, values, 100000);
}
adc11_stop ();
adc11_close_unit(101);


Best Regards
Harald Weber
Harald Weber
 

Postby Michael » Tue Nov 01, 2005 4:19 pm

Hello,

The drivers for the USB ADC11 have been recently updated.

Try downloading the dirvers from our website and let me know how you get on.

Best regards,
Michael
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

Postby Harald Weber » Wed Nov 02, 2005 8:18 am

Hello Michael,

I loaded the new Driver from your website, but the result is the same as before.

Best regards,

Harald Weber
Harald Weber
 

Postby Sarah » Tue Nov 08, 2005 9:49 am

Hi Harald

Thank you for your post.

If you use Picolog do you still get these high readings?
At what point do the readings occur? Is it all the time or just at the beginning or a certain time?

If you can let me know some more information then this will help us find the root of this issue.

Best Regards
Sarah
 

Me Too!

Postby AndyC » Thu Nov 10, 2005 4:52 pm

I get this too!
I downloaded the new drivers this afternoon.
It looks like the first 6 values returned from adc11_get_times_and_values are often 65535.

When I use the demo program to stream the data, I get loads of discontinuities in the log file. I thought streaming was supposed to get round this?
AndyC
 


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests