Test and Measurement Forum

Missing Libraries

Post your MATLAB discussions here

Missing Libraries

Postby arb93 » Tue Sep 29, 2015 8:50 pm


I am trying to connect the ps5440b oscilloscope to MATLAB. I am running a 64 bit Windows 7 OS. As a first step, I downloaded and installed the appropriate SDK.

When I try to connect, I get the following errors:

Error using instrument/delete (line 82)
Operation failed: An error occurred while executing the driver disconnect code.
Library was not found
If this error is not an instrument error, use MIDEDIT to inspect the driver.

Error in icdevice (line 310)

Any help would be appreciated.

Posts: 0
Joined: Tue Sep 29, 2015 8:47 pm

Re: Missing Libraries

Postby Hitesh » Mon Oct 05, 2015 11:34 am

Hi arb93,

You may have been missing one of the dll files that is required to be on the MATLAB path.

Based on your e-mail support ticket, I can see that you have resolved the issues encountered. If you do require further assistance, please post back here or reply to your support ticket.

If you are calling the Instrument Driver code from within a function which I believe you were in your e-mail support enquiry, then you will need to use the information referred to via this post. We will look to resolve this in a future release.


Technical Specialist
Pico Technology
Site Admin
Site Admin
Posts: 2026
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Return to MATLAB

Who is online

Users browsing this forum: No registered users and 0 guests