Cannot start PicoScope 6 on OS X 10.10

Discussion forum for the new Picoscope Mac software
Post Reply
R. Schmitz
Newbie
Posts: 0
Joined: Thu Sep 24, 2015 6:04 pm

Cannot start PicoScope 6 on OS X 10.10

Post by R. Schmitz »

Hello,
I just downloaded the PicoScope for Mac v6.11.6.31 from your web-site. When I was asked from you App I download and installed the Mono package (Mono Framework MDK-4.04.1) too.
However I still get the dialog “Mono installation not found. Go to Mono Project download page now?”.

To validate the Mono-Installation and build and run the basic apps from the Mono Basics page [1] successfully.

How should I start PicoScope?
Edit: The start via GUI does not work. A start at command “/Applications/PicoScope6.app/Contents/MacOS/picoscope” is possible.

Kind Regards from the Magdeburger Börde,
R. Schmitz

Remark:
I have connected a PicoScope 3403D, OS X is 10.10.4
[1] Mono Basic:
http://www.mono-project.com/docs/gettin ... no-basics/#

Martyn
Site Admin
Site Admin
Posts: 3872
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Cannot start PicoScope 6 on OS X 10.10

Post by Martyn »

Thank you, This has been passed on to the development team as part of the ongoing Beta development of the software on OS X.
Martyn
Technical Support Manager

Phabyain
Newbie
Posts: 0
Joined: Fri Nov 13, 2015 8:15 pm

Re: Cannot start PicoScope 6 on OS X 10.10

Post by Phabyain »

Hello,
I have a Picoscope 2204A, I have installed PicoScope V6.11.6.31 and Mono Framework V4.0.4.4, on Imac with Mac OS 10.9.5.
I always get the message "Mono Installation not found. Go to Mono Project download page now ?" whereas Mono is well installed.

Thank you very much R.Schmitz, the command below in a Terminal works !

Code: Select all

/Applications/PicoScope6.app/Contents/MacOS/picoscope
Picotech team, please, can you verify the mono installation check when using Picoscope Icon in Application folder ?
thank you.

Hitesh
Advanced User
Advanced User
Posts: 2856
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Cannot start PicoScope 6 on OS X 10.10

Post by Hitesh »

Hi Phabyain,

We have just released a new version of the PicoScope 6 application - please refer to this post.

Regards,
Hitesh

Software Dev. Engineer

Phabyain
Newbie
Posts: 0
Joined: Fri Nov 13, 2015 8:15 pm

Re: Cannot start PicoScope 6 on OS X 10.10

Post by Phabyain »

Hi Hitesh,
I install last version V6.11.8.5, it works fine !
thank you for your quick answer and update.
best regards.

Hitesh
Advanced User
Advanced User
Posts: 2856
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Cannot start PicoScope 6 on OS X 10.10

Post by Hitesh »

Hi Phabyain,

Thank you for confirming that this version works :D

Regards,
Hitesh

Software Dev. Engineer

ArmyChief
Newbie
Posts: 0
Joined: Tue Jan 05, 2016 8:11 pm

Re: Cannot start PicoScope 6 on OS X 10.10

Post by ArmyChief »

Just bought a Macbook 12. Pico 6.11.8.11 will not open at all.
Installed Mono 4.2.102 tacos.xamarin.x86 (a link to the PROPER installer of Mono, might be beneficial in the Pico Installer at bottom).

Can anyone suggest where I should go from here?

AndrewA
PICO STAFF
PICO STAFF
Posts: 283
Joined: Tue Oct 21, 2014 3:07 pm

Re: Cannot start PicoScope 6 on OS X 10.10

Post by AndrewA »

Hi ArmyChief,

Check you are using a Mono version 4.0.4.1-1 or earlier.
The recent versions of mono can cause is issues with PicoScope.
To find out what version of mono you have installed use the command-

Code: Select all

mono --version
Mono version 4.0.4.1-1. Can be download here-
http://download.mono-project.com/archiv ... in.x86.pkg

Then follow the steps here- topic19641.html#p63291
Regards Andrew
Technical Specialist

ArmyChief
Newbie
Posts: 0
Joined: Tue Jan 05, 2016 8:11 pm

Re: Cannot start PicoScope 6 on OS X 10.10

Post by ArmyChief »

Thanks for the quick reply.

I eventually got it to work with the latest 4.2 Mono.

I installed CleanMyMac and did a removal of PicoScope SW and then a full clean of machine.

Then re-installed Mono, then Pico. Seems to work for now. i'll download the 4.0.4 version and keep your remarks in mind if Pico acts up.

Post Reply