Synchonising SigGen and Capture

Post any questions you may have about our current range of oscilloscopes
Post Reply
Frank P
Newbie
Posts: 0
Joined: Fri Sep 18, 2015 6:31 am

Synchonising SigGen and Capture

Post by Frank P » Fri Sep 18, 2015 7:18 am

Hello Picotech Team,

I'm a student from germany working on my bachelor thesis. I'm building an automated measurement system using the Picoscope 5243B and LabView.
The sending-signal is a burst of 20 shots. Then I need to capture the complete sequence including the starting-signal and the system response. Therefore I need to synchronise the signal generator and the capture.

In PicoScope 6 I can set a single trigger and the capture "waits" for the signal generator to trigger.
But for the api I read that it is not possible to start the capture before the signal generator. And if I start the capture directly after triggering the signal generator I have a delay of approx 5 ms before the capture starts.

How can cut the delay or, better, synchronise signal generator (awg) and capture? (preferably in LabView or C)

Thanks
Frank

Hitesh
Site Admin
Site Admin
Posts: 2812
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Synchonising SigGen and Capture

Post by Hitesh » Fri Sep 18, 2015 9:39 am

Hello Frank,

You may wish to refer to this guide on triggering the signal generator using the API functions.

The calls to set up the signal generator and trigger conditions needs to be made prior to starting the data capture.

Regards,
Hitesh

Technical Support Engineer

Frank P
Newbie
Posts: 0
Joined: Fri Sep 18, 2015 6:31 am

Re: Synchonising SigGen and Capture

Post by Frank P » Fri Sep 18, 2015 11:46 am

My problem is not how to trigger the signal generator, but to start the signal generator and the capture at the same time (if possible).
If I start the capture after triggering the signal generator, the capture has a delay and I miss the first part of the signal (about 5 ms).
Is it possible to use SCPI? Or a trigger delay for the signal generator?

Hitesh
Site Admin
Site Admin
Posts: 2812
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Synchonising SigGen and Capture

Post by Hitesh » Mon Sep 21, 2015 10:43 am

Hi Frank,

If it is possible to set the signal generator to output a signal and then wait for a trigger in the PicoScope 6, then it is possible to achieve this using the API function calls provided by the dll.

Would it be possible for you to post the psdata or pssettings settings file from the PicoScope 6 software so that we can take a look at your settings?

Thanks,
Hitesh

Technical Support Engineer

Post Reply