Test and Measurement Forum

Frequent "hangs" and crashes when working with large decodes

Forum for discussing PicoScope version 6 (non-automotive version)

Frequent "hangs" and crashes when working with large decodes

Postby FullBoar » Wed Aug 26, 2015 2:41 am

So, I'm using a 3406D MSO, with PicoScope set up at 500ms/div, and 20MS. I'm only capturing a single pane/window of data as I was getting data losses between panes/windows.

I've been trying this with the latest stable release, and recently with the beta as well. In the last hour I've had four crashes (the application force exits) and one "not responding" that hadn't recovered after a few minutes (using 6.10.16.2 - crashes in beta versions don't count)

Half the time the tool crashes while decoding, and most recently then has problems while moving around inspecting decoded data.

I've also discovered that once PicoScope starts decoding serial data you can't stop it... Even starting another capture just gets ignored.

My PC is Win7 SP1, i7-4800 with 16Gb RAM on a Samsung 840 Pro SSD...

Any suggestions please?
FullBoar
Newbie
 
Posts: 0
Joined: Tue Aug 25, 2015 11:40 pm

Re: Frequent "hangs" and crashes when working with large dec

Postby Hitesh » Thu Aug 27, 2015 9:34 am

Hi FullBoar,

Please continue to use the PicoScope 6.11 Beta software as the Serial Decoding feature has undergone rework with a new interface and it is this engine that we will continue to use moving forward.

Please save the crash report zip files from the Beta software and e-mail it to support@picotech.com as this will contain useful information in order to help determine the cause of the crash.

If the application stops responding, please end the application via the Windows Task Manager then locate the corresponding trace.xml file as shown in section 3 of the PicoScope 6 Self-Help Guide. Please e-mail the file to our support address.

Thanks,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests