Test and Measurement Forum

RapidBlock Mode and the Time until the trigger event

Post your LabVIEW discussions here

RapidBlock Mode and the Time until the trigger event

Postby aknopf » Wed Aug 12, 2015 1:53 pm

Hi,

i work with the picoscope 4424.

I use the rapidblock mode and i will find out the time between the start and the first trigger and the next trigger. Therefor i use the ps4000GetValuesTriggerChannelTimeOffsetBulk64 function. With theses function i get the times and the timeUnits. But the times are negative and look like random, not constant. The timeUnits are 0.
Now i have 2 questions.
Can you explain the negative numbers and the 0 at the timeUnits?
Is an other functon better to find out the time between the start and the trigger point?


Thanks
aknopf
Newbie
 
Posts: 0
Joined: Wed Aug 12, 2015 6:36 am

Re: RapidBlock Mode and the Time until the trigger event

Postby Hitesh » Tue Aug 18, 2015 1:06 pm

Hi aknopf,

Unfortunately, the ps4000GetValuesTriggerChannelTimeOffsetBulk64 function does not return the time from the start of the capture to the trigger events.

Please refer to this post for an explanation of the function.

The zero in the time units refers to the enumeration PS4000_FS (Femtoseconds). The negative value indicates that the trigger occurred just before the first sample in the segment.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 1 guest