Measurement in Scope mode

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
solari48
Newbie
Posts: 0
Joined: Wed Jul 15, 2015 11:50 am

Measurement in Scope mode

Post by solari48 » Wed Jul 15, 2015 2:20 pm

Hi,

I am measuring AC current through 2 channels of the PicoScope. I want to keep my setup parameters that are:

Time period: 1 second
Sample interval: 1 uS
Sample rate: 1 MS/s
Number of samples: 1,000,000
Hardware Resolution: 15 bits
Number of buffers: 32

With the above setting the total time it takes for 32 buffers measurement is almost 41 seconds. My intention is to do this measurement and get the results saved every 5 or 10 minutes automatically. I have tried to do it using Alarm settings but it is not helpful since PicoScope does the time domain measurements very fast per buffer. I like to know if there is a way to introduce some delay in per buffer measurement so to get the total measurement time around 5 or 10 minutes for 32 buffers with the above parameters and store the data automatically?

Mark_O
Advanced
Posts: 44
Joined: Fri Oct 03, 2014 5:58 am

Re: Measurement in Scope mode

Post by Mark_O » Mon Jul 20, 2015 12:49 am

Hi Solaris.

The way I am reading this, each segment is capturing a 1 sec burst of data. And currently, it is retriggering 'immediately' (well, about 250 ms gaps), so all the segments are back-to-back. And what you would like to do is space them out, so that those 32 one-second bursts are evenly distributed across 5-10 minutes. Is that correct? So there would be one burst every 15 seconds (for an 8 min example)?

If this is the case, and the data is constantly retriggering as soon as you re-enable, one way to accomplish that would be to add a post-trigger delay for each acquisition. I.e., you can specify the number of events that have to occur, before the next trigger will fire. This should easily allow you to skip 14 seconds (or whatever you like), between each 1 second burst.

- Mark

Martyn
Site Admin
Site Admin
Posts: 3225
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Measurement in Scope mode

Post by Martyn » Tue Aug 04, 2015 10:36 am

What signal are you looking at and what measurement are you taking ?

Using a trigger delay may work, but that will depend upon the specific characteristics of the data you are looking at.

If possible post a psdata file showing the signal, and measurement, applied to just one buffer.
Martyn
Technical Support Manager

Post Reply