ADC100 & USB->parallel

Forum for discussing PicoScope (version 5)
Post Reply

ADC100 & USB->parallel

Post by sartory » Thu Feb 27, 2003 5:22 am

I have an ADC100 that has been working OK on a Dell CPt laptop. Today I installed a Pico USB->parallel adapter. When I start Picoscope, it runs OK with data displayed for about 1 minute, & then it dies with the error message:

Assertion failed: (current_unit_ptr->state==US_BLOCK_completed)||
file a100usb .c, line 656

When I click "OK", I get the further message"

Abnormal program termination.

When I click "OK" again, Picoscope shuts down.

My OS is WIN98SE. It does not die on these Picoscope crashes.

I tried removing & re-installing the Pico software several times with no effect.
I tried updating to the latest Pico software with no effect.
I tried updating to the latest MS WIN software with no effect.

I tried installing this same Pico hardware & software on a desktop PC running WIN2k, & it seems to run fine there.

Walt Sartory


Post by gatj98 » Fri Feb 28, 2003 11:04 am

I've had this when writing my own software. It seems to be the adc100_get_times_and_values driver function that causes this. Only on mine it's line 657 that gives the error message. I couldn't find a file called adc100usb.c at all on my machine. Im using winxp pro.
Do you use the parallel adapter between your adc100 and the usb port?


Post by sartory » Sat Mar 01, 2003 2:46 am

No, I can't find a file named a100usb.anything on my system either, so I don't know from where this error message is written, but it is quite reproducible.

I have been plugging the usb->parallel converted directly into the adc100. This gives correct results for the one minute until Picoscope crashes, so I doubt it it wrong.


User avatar
Advanced User
Advanced User
Posts: 109
Joined: Wed Sep 25, 2002 9:35 am
Location: Cambridgeshire, UK

Post by matthew » Thu Mar 06, 2003 8:55 am

Hi Walt,

The error message is an assertion failure and the file 'a100usb.c' is source code so it is not distributed with the application (this is for our own debugging purposes).

The bug you have found is known by Pico and we are currently looking to fix this. Look out for our next software release by subscribing to the newsletter here.

(You won't need to use the adapter when using the usb adapter)

Best Regards,
Matt Everett

Pico Software Engineer


Post by sartory » Thu Mar 06, 2003 4:44 pm




Post Reply