Test and Measurement Forum

I2C Decode, 5000 Series, Linux

Discussion forum for the new Picoscope Linux software

I2C Decode, 5000 Series, Linux

Postby wharvey » Thu Jun 25, 2015 3:01 am

I notice that the Linux version is still in Beta after 6 months with no updates.
I couldn't find how to use the I2C decoding with my Linux version.
I tried to install the software in a Windows 8.1VM under Linux but the software was unable to find the Picoscope.
Yes, I had the USB port mapped to the VM.
I tried both USB2 and USB3 mappings.
I am using Ubuntu 15.04 with VirtualBox for the VM.
So long as I use 8-bit resolution the scope runs well although if I try to shut it down after a couple of days it hangs.
If I try to use 12-Bit resolution, the program hangs/crashes after about half a day of use.
We purchased two of the scopes, one 5000 series, and one 3000 series based that they were advertised to run under Linux.
Do you plan to continue support for Linux?
By the way, the Ubuntu 15.04 install went without any issues.
wharvey
Newbie
 
Posts: 0
Joined: Thu Jun 25, 2015 2:52 am

Re: I2C Decode, 5000 Series, Linux

Postby Hitesh » Thu Jun 25, 2015 1:20 pm

Hi wharvey,

The Serial Decoding feature has undergone work recently in order to provide improvements, which is why this feature has not been ported across into the Linux (and Mac) version as yet.

There is a PicoScope 6 Beta (6.11) version for Windows which can be downloaded from:

https://www.picotech.com/downloads

We are looking to achieve feature parity with the Windows version for both Linux and Mac platforms in due course.

Which PicoScope 5000 Series model are you using and are you using the power supply if it is a 4-channel device?

With regards to the non-detection of the scope through the virtual machine, is it displayed in the Windows Device Manager? If so, please locate the trace.xml file (see section 3 of the PicoScope 6 Self-Help Guide) and either post it here or e-mail it to support@picotech.com

Regarding the crash with the Linux version, please could you provide a PicoScope settings file with the exact settings that you have been using so that we can try to reproduce it here.

Best wishes,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests