Test and Measurement Forum

Repeating Rapid Block Acquisition

Post your LabVIEW discussions here

Repeating Rapid Block Acquisition

Postby mhinds » Fri Jun 19, 2015 7:59 pm

Hi,
I have a 5244B. I'm trying to use Rapid block mode to capture 30000 waveforms, (3840 points each), download the block, process the data, then capture the next set of waveforms. (Code attached, using LabWindows 2013)

It seems to work once, I display waveforms on the screen, but get a general protection fault acquiring the next block.

A couple questions:
Am I missing a step in cycling to capture more data?
Also, the GetValuesBulk command need to be broken into 1000 capture segments to transfer properly. Is this a hardware limitation of my PC?

Thanks for the help,
Mike Hinds
mhinds
Newbie
 
Posts: 0
Joined: Fri Jun 19, 2015 7:47 pm

Re: Repeating Rapid Block Acquisition

Postby Hitesh » Mon Jun 22, 2015 3:51 pm

Hi Mike,

Which version of the ps5000a.dll and LabVIEW (32/64-bit) are you using?

Are you calling the ps5000aStop function once you have collected data before starting the data capture again? Can you post the error message received please?

There should not be a limit for the ps5000aGetValuesBulk call (apart from the maximum number of segments for the device). What result are you seeing if you try to retrieve more than 1000 waveforms from the device?

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Repeating Rapid Block Acquisition

Postby mhinds » Mon Jun 22, 2015 4:08 pm

Hitesh,

I am using LabWindows/CVI 2013 (not LabVIEW) as my development environment.

The ps5000a.dll Version is 1.1.4.20.

If I try to return 10000 buffers per call of GetValuesBulk, I get the attached error message. There is a ps5000AStop call in place. I will investigate the max number of buffers (between 1000 and 10000) I can retrieve without error.

Thanks,
Mike Hinds
Attachments
PicoError.png
GetValuesBulk error
mhinds
Newbie
 
Posts: 0
Joined: Fri Jun 19, 2015 7:47 pm

Re: Repeating Rapid Block Acquisition

Postby Hitesh » Mon Jun 22, 2015 4:24 pm

Hi Mike,

Thanks for the information,

Could you please e-mail support@picotech.com indicating if you require a 32-bit or 64-bit driver and we can provide an updated one which may resolve the issue.

A new SDK is due to be made available soon.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Repeating Rapid Block Acquisition

Postby mhinds » Tue Jun 23, 2015 3:05 pm

Hitesh,

I found my mistake. I did not initialize the Overflow variable in the ps500aGetValuesBulk call as an array equal to the number of captures I required.

Thanks for your help with this.

Mike Hinds
mhinds
Newbie
 
Posts: 0
Joined: Fri Jun 19, 2015 7:47 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests