Test and Measurement Forum

PicoLog 1000 Series problem with Labview 2014 64 bit

Post your LabVIEW discussions here

PicoLog 1000 Series problem with Labview 2014 64 bit

Postby gamemakerh » Fri May 29, 2015 1:28 pm

I am very fresh with labview and pico hardware.
I encountered problem when I do not know What that handler do in picoLog example files.

Why handle have to be 0 ? and why my PICO_STATUS is 3 ?

Does it mean that 3 -> 03 -> PICO_NOT_FOUND ?

I trying debug with pl1000OpenUnit block

Code: Select all
This function opens and enumerates the unit

Returns:
PICO_OK
PICO_OS_NOT_SUPPORTED
PICO_OPEN_OPERATION_IN_PROGRESS
PICO_EEPROM_CORRUPT
PICO_KERNEL_DRIVER_TOO_OLD
PICO_FW_FAIL
PICO_MAX_UNITS_OPENED
PICO_NOT_FOUND              <-------------  This error code is on my example ? yes ?
PICO_NOT_RESPONDING

handle: the function will write a value here that uniquely identifies the data logger that was opened. Use this as the [handle] parameter when calling any other PicoLog 1000 Series API function
Attachments
picolog_problema.jpg
Problem
gamemakerh
Newbie
 
Posts: 0
Joined: Fri May 29, 2015 1:10 pm

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby gamemakerh » Mon Jun 01, 2015 1:46 pm

I managed to fix that error, but I encountered with another problem.

pl1000GetUnitInfo block is mistery for me...

Code: Select all
This function returns a string containing the specified item of information about the unit.

Returns:
00 PICO_OK
0C PICO_INVALID_HANDLE
16 PICO_NULL_PARAMETER
29 PICO_INVALID_INFO
2A PICO_INFO_UNAVAILABLE

handle: handle returned from
pl1000OpenUnit
pl1000OpenUnitProgress

string: a location where the function writes the requested information, or [NULL] if you are only interested in the value of [requiredSize]

stringLength: the maximum number of charakters
that the function should write to [string]

requiredSize: a location where the function writes the length of the information string before it was truncated to [stringLenght]. If the string was not truncated then [requiredSize] wil be less than or equal to [stringLength].

info: the information that the driver should return. These values are specified in [picostatus.h]
PICO_DRIVER_VERSION
PICO_USB_VERSION
PICO_HARDWARE_VERSION
PICO_VARIANT_INFO
PICO_BATCH_AND_SERIAL




From labview I get this:
PICO_STATUS 13 (decimal) 0D (hex). does it mean that 0D error is PICO_INVALID_PARAMETER ?




How to fix this problem ?

BTW I found mistake in programers guide (I think) PICO_INFO have to be Unsigned Long 32 integer with pointer.


This is screen of my program.
Attachments
screenas.JPG
gamemakerh
Newbie
 
Posts: 0
Joined: Fri May 29, 2015 1:10 pm

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby Hitesh » Wed Jun 03, 2015 4:29 pm

Hi gamemakerh,

Could you please detail the data types for the parameters defined in the Parameters tab of the pl1000GetUnitInfo Call Function Library Node?

It's possible that a data type might be defined incorrectly.

You are right, the PICO_INFO type should be an unsigned 32-bit integer as that is how it is defined in the picoStatus.h file in the SDK.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2009
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby gamemakerh » Mon Jun 15, 2015 1:47 pm

This is all blocks which I created with Programmers guide.
Attachments
PICOLOG_DLL_PROGAMA_R1.vi
(14.17 KiB) Downloaded 47 times
gamemakerh
Newbie
 
Posts: 0
Joined: Fri May 29, 2015 1:10 pm

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby AndrewA » Mon Jun 22, 2015 4:26 pm

Hi gamemakerh,

I opened your vi file, PICO_INFO in pl1000GetUnitInfo function is value not a pointer.
See page 10- https://www.picotech.com/download/manuals/pl1000pg-en-3.pdf
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby gamemakerh » Tue Jun 30, 2015 10:33 am

When I change Pointer to Value only and try to run program, Labview Instantly Crash.
gamemakerh
Newbie
 
Posts: 0
Joined: Fri May 29, 2015 1:10 pm

Re: PicoLog 1000 Series problem with Labview 2014 64 bit

Postby Hitesh » Mon Jul 06, 2015 1:24 pm

Hi gamemakerh,

Could you please post the following screenshots:

1. What inputs are going into the Call Function library node (if it has changed from your earlier post).
2. The Properties windows for the pl1000GetUnitInfo Call Function Library Node so we can see how each of the parameters has been defined.

Thanks,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2009
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 1 guest