Test and Measurement Forum

Problem with Picolog displays

Forum for discussing PicoLog

Problem with Picolog displays

Postby Glovisol » Wed May 06, 2015 3:35 pm

Picolog seems to have the following display problem, which I found while operating the DrDAQ, but suspect it as an obvious software problem.

When measuring two or more quantities having, at one stage, the same value or values very near to each other and it is desired to display these quantities with the SEPARATE GRAPHS option, once the values become nearly identical or identical, only one plot remains, while the other plots become empty and their scale factor changes to a wrong value. With two quantities, one display disappears, with three, two disappear and so on. The only remedy seems to be, in this case, that of displaying all quantities IN THE SAME GRAPH. Unfortunately then, if other quantities, with great difference in value, have to be displayed, the resulting display is far from satisfactory.....
Glovisol
Advanced User
Advanced User
 
Posts: 114
Joined: Sat May 11, 2013 10:03 am
Location: San Marzano Oliveto, Asti, Italy

Re: Problem with Picolog displays

Postby Hitesh » Mon May 11, 2015 11:22 am

Hi Glovisol,

Could you please provide the PicoLog settings (*.pls) file for the recording and post it here or e-mail it to support@picotech.com

Which channels are you logging from?

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Problem with Picolog displays

Postby Glovisol » Wed May 13, 2015 11:30 am

Dear Hitesh,

Herewith enclosed PLW file Barometer 1800a. that shows the described display phenomenon. Data collected with USB DrDAQ where the EXT. inputs were used, but all data is available from the PLW file.

Kind regards,

Glovisol
Attachments
Barometer 1800a.PLW
PLW file showing display problems with data having same or very similar values
(29.21 KiB) Downloaded 107 times
Glovisol
Advanced User
Advanced User
 
Posts: 114
Joined: Sat May 11, 2013 10:03 am
Location: San Marzano Oliveto, Asti, Italy

Re: Problem with Picolog displays

Postby Hitesh » Thu May 21, 2015 12:36 pm

Hi Glovisol,

Thank you for this.

I will report a bug although given that the software is under maintenance, a fix might be unlikely unless it is deemed to be a significant issue by our Development Team.

You may wish to consider using the PicoScope 6 software if you are going to be capturing data for short periods of time.

Update: If you choose to use PicoScope 6, you can make use of Maths Channels or Custom Probes to make calculations and use the Alarms feature to save data to disk when a capture has occurred or the waveform buffers are full.

Update 2: After investigation, it appears that the scaling for the calculated parameters for your Barograph 3 and Barograph 1 parameters might not be correct. First correct the scaling:

  • Close the graph
  • Click Settings -> Calculated Parameters
  • Select the parameter from the list
  • Click Edit
  • Click Options
  • Adjust the Scaling for graphs minimum and maximum value
  • Accept changes
  • Open the graph view again
  • Save the data file with another name to retain settings.

Click on the little '+' in the top left corner of the graph and adjust the vertical axis. To apply the changes click the '-' icon that appears in place:

PicoLog_Separate_Graph_Scaling_tool.PNG
Graph view


You can also use the magnifying buttons at the top of the window for vertical zoom or the up down to keep the zoom level the same but shift the vertical position upwards or downwards.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 1997
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoLog

Who is online

Users browsing this forum: No registered users and 0 guests