Test and Measurement Forum

Visual Basic and "adc11_get_values"

Post general discussions on using our drivers to write your own software here

Visual Basic and "adc11_get_values"

Postby FlexyZ » Mon Jun 20, 2005 7:39 pm

Hi

Just got ADC11 USB, and picoscope works.

But Visual Basic example (downloaded latest drivers) are not working with "FAST" (adc11_get_values)

Error:

MEMMGR:
Attempt to lock unknown global
File \Pico\Prod\Adc11\Windrv\Adc11usb.c line 1039

Run-time error '11':

Division by zero

****************

After some searching in the forum, there seems to be missing :

adc11_run
adc11_ready

Why are the example not working? and even with function declarations missing.

Thanks
Felix


PS. Anyone got a .NET wrapper working?
FlexyZ
User
User
 
Posts: 2
Joined: Mon Jun 20, 2005 4:28 pm

Postby Sarah » Thu Jun 23, 2005 10:28 am

Hi

Thank you for your post.

On closer inspection it does seem that there are two lines missing in the code for the USB unit. These are the lines taht you have identified.

We have updated our files here and if you require a copy of the updated code then please email us at tech@picotech.com and let us know.

Best Regards
Sarah
 

Postby FlexyZ » Fri Jun 24, 2005 11:26 am

Hi

I added the lines myself, but still not working.

But I am using .NET C# now, I finally got my wrapper working - still need some work though.

Felix
FlexyZ
User
User
 
Posts: 2
Joined: Mon Jun 20, 2005 4:28 pm

Postby dundas » Wed Aug 24, 2005 8:15 am

FlexyZ:

I just added them externally

Code: Select all
    Declare Auto Function adc11_run Lib "adc1132.dll" (ByVal no_of_values As Long, ByVal method As Short)
    Declare Auto Function adc11_ready Lib "adc1132.dll" () As Short


in a module, and it worked like a charm.
dundas
User
User
 
Posts: 4
Joined: Wed Aug 24, 2005 2:12 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests