Test and Measurement Forum

installation blues

Forum for discussing PicoScope (version 5)

installation blues

Postby jb76 » Sun Jun 05, 2005 11:26 pm

Hi we have got a pico3205 for our lab. we r not able to install the picoscope software properly, we have tried using the installation guide but it's not working properly. when we try to open picoscope it gives error that could not find pico3000 series. can somebody guide us through proper installation procedure please.

big problems with installation

Postby Guest » Tue Jun 07, 2005 4:55 am

we have followed the instructions of the installation word for word. on upto 7 machines running windows XP sp2. we have had absolutely no luck getting the picoscope 3205 up.
the steps taken by us are:
1) install the software on picoscope cd (R.17), without the picoscope attached
2) restart the computer (after full powerdown reboot)
3) connect the picoscope to the USB, after windows has restarted - upon which all machines report that the oicoscope 3000 series has been connected to a low speed USB. it does not ask for any type of driver installation. the drivers seem to be detected. [i have connected the scope and restarted, with same results.]
4) windows suggests unplugging the device and plugging it into another port to allow the device to use a high speed USB 2.0
5) if we try running the picoscope software at this stage, we get the error failed to open picoscope 32XX. (windows device manager shows that the driver is loaded and the picoscope 3200 scope is detected and connected, etc)
6) if we keep changing the USB connectors (the computers have 6 USB ports), after many re plugs, it sometimes gives us the new hardware found wizzard. we point it to the c:\windows\inf\ folder from where it uses the picopp.inf and .sys files. everything seems to work. windows device manager shows that the driver is loaded etc.
7) if we launch the picoscope program we get the same error - failed to open picoscope 32XX. error code in help | about is - error code 4

we have tried installing this in every way possibe. force loading drivers. deleting registry entries. reloading software. name it .. everything. i have tried the picoscope on windows 98 too .. same result

the scope lights up, when the driver is loaded. when the software launches and it says failed to oprn 32XX .. then the scope light goes off.

why is the installation so painful? .. why cant the picoscope be installed like any other hardware device? we have tried this process *atleast* 350 to 400 times .. across these 7 machine. it may sound ridiculous!
we have wasted tremendous amount of time on this.
please release drivers and solutions that work out of the box. i think that has to be a minimum. i dont know what excuses can be thought up of. but this is a serious compromise. even open source linux solutions in many cases is MUCH better.
i suggest you need to have much better diagnostics programs .. or a installation wizzard .. that can do some diagnostics. have some method by which you can find out what is going wrong .. either in drivers loading, USB configuration, in windows, whatever.. let the user know what is happening.

the instructions on the installation guide seem simple. but 7 machines cannot be wrong. we cant get it to work on any of the 7 machines. if it is install drivers/ software first. then restart the machine, plug in scope, point to drivers .. get scope detected .. and then run the picoscope software. this does not work in our case.

plus i have tried the latest software from your website - same results.

please suggest a remedy.
thank you,

Postby Sarah » Tue Jun 07, 2005 9:44 am


Thank you for your post, I am sorry to hear that you have been seeing problems.

Firstly, the notice about the unit being plugged into a low speed port is normal - this is due to the way that the unit first talks to the computer when it you plug it in. You just need to ignore this message. If the port is a USB2 port then it will start to work on USB2 when the software is started.

When you are opening the software up, and it is not finding the unit, do you have the power supply connected to the unit? I would suggest trying having the unit plugged into the mains as it may be that the computer is not supplying quite enough power.

When you start the software it re-enumerates the USB device, try watching the device manager whilst the software is opening and see if it reappears after it disappears - if it does, what does it display as?

Hope this helps

Best Regards

Return to PicoScope 5

Who is online

Users browsing this forum: No registered users and 0 guests