Test and Measurement Forum

PicoScope 5000 series using LabVIEW2014 64 bit

Post your LabVIEW discussions here

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby ahmadtarmimi » Wed Aug 26, 2015 8:17 am

Good Day AndrewA

Thanks for your strong support as always

equipment: picoscope5244B

I have been taking measurement data using the picoscope 6 software ; result good waveform

but using picoscope with the labVIEW... example "PicoScope5000aExampleBlock"; there is a noise consider abnormal waveform.

is it related to ADC (analogue to digital converter) or labVIEW programming problem ?

is there any example VIs that have similiar waveform with picoscope6 software?

Best Regards
Tarmimi
ahmadtarmimi
Newbie
 
Posts: 0
Joined: Sun Mar 22, 2015 3:18 pm

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby ahmadtarmimi » Thu Aug 27, 2015 9:20 am

Good Day AndrewA

what i meant by "but using picoscope with the labVIEW... example "PicoScope5000aExampleBlock"; there is a noise consider abnormal waveform."-->>>" graph Amplitude (16-bit ADC counts) vs sample"

is there any example VIs that have similiar waveform with picoscope6 software?---> desire waveform graph is voltage vs time domain"

i made some adjustment vis(PicoScope5000ExampleBlock) previously use for picoscope 5203 change to PicoScope5000aExampleBlock for picoscope 5244B "voltage vs time domain graph" in attachment but its not working...

hopefully you can advise
Best Regards
Tarmimi
Attachments
PicoScope5000aExampleBlock voltage vs time.vi
(20.14 KiB) Downloaded 56 times
ahmadtarmimi
Newbie
 
Posts: 0
Joined: Sun Mar 22, 2015 3:18 pm

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby AndrewA » Fri Aug 28, 2015 9:33 am

Hi Tarmimi,

I post a simple vi to convert ADC counts to volts on this post-
https://www.picotech.com/support/topic19071.html?hilit=adc%20to%20volts#p59221
Adding this vi is a very simple change. In future we would like to include this in all our examples.
I did download your vi above but openunit vi seemed to have changed.

Regarding your previous post about ADC-noise can post a screen shot of the issue.
Read page 4 regarding Aggregation-
https://www.picotech.com/download/manuals/PicoScopeUSBStreaming.pdf
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby ahmadtarmimi » Tue Sep 01, 2015 2:02 am

Good Day AndrewA

Thanks for the information... :D

Best Regards
Tarmimi
ahmadtarmimi
Newbie
 
Posts: 0
Joined: Sun Mar 22, 2015 3:18 pm

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby ahmadtarmimi » Mon Sep 28, 2015 8:43 am

Good day AndrewA

Can you give an advise on using the get time base API programming ... where should i put the API programming? after the run block or before the run block right after( refer attachment)

is it possible to give an example...? still not get the basic idea on how to use the get time base API...

Best Regards
Tarmimi
Attachments
get time base.png
ahmadtarmimi
Newbie
 
Posts: 0
Joined: Sun Mar 22, 2015 3:18 pm

Re: PicoScope 5000 series using LabVIEW2014 64 bit

Postby AndrewA » Tue Sep 29, 2015 11:21 am

Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Previous

Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests