Test and Measurement Forum

TC-08 - Voltage measuring

Post any questions you may have about our current range of USB data loggers

TC-08 - Voltage measuring

Postby battywoo » Fri Mar 20, 2015 6:35 pm

We currently use TC-08 for temperature and voltage measuring. Channel 1-6 are for thermocouples inputs while channel 7-8 are for voltage measuring (0-5V). We got two TC-08 Single-Channel Terminal Boards to convert the voltage. (switch set to OFF).

The problem is that when we try to measure the voltages from a circuit, the readings of all channels get crazy. Seems that the introduction of voltages interfere the whole system. The circuit is powered by a power supply and the TC-08 is connected to a laptop with power plugged. They are connected to the same power outlet.

BTW, if we try to measure the voltage of a AA battery, the readings seem good.
Could you please provide us some ideas to solve this problem? Thanks
battywoo
Newbie
 
Posts: 0
Joined: Fri Mar 20, 2015 6:18 pm

Re: TC-08 - Voltage measuring

Postby Martyn » Tue Mar 24, 2015 2:40 pm

Try with the laptop running on it's battery, and if this doesn't fix things then try to make sure that there is a common ground between your circuit and the laptop, plugging into the same power outlet may not be sufficient.

What are the thermocouples connected to and measuring ?
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2716
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: TC-08 - Voltage measuring

Postby battywoo » Tue Mar 24, 2015 3:18 pm

Thank you for the reply. Laptop running on battery didn't fix that.

The thermocouples are grounded K-type thermocouples to measure the temperatures in a burner. Some of them touch the metal surface. Some are not.

I will try to connect the common ground of the circuit to the burner's metal surface to see if that works.
battywoo
Newbie
 
Posts: 0
Joined: Fri Mar 20, 2015 6:18 pm

Re: TC-08 - Voltage measuring

Postby fredrik » Fri Oct 30, 2015 11:58 am

Battywoo: did it fix your problem? I have the same issue. If i put in the single channel terminal board and measure voltage (0-5V) the thermocouple readings go crazy. If I then connect the terminal board to ground the thermocouples are good but the voltage measurement is wrong (more than if not grounded). Can also this be a problem of having different earthing locations for the computer and the terminal boards?

Previously I solved this by having only one terminal board per TC08 logger, but it is an expensive solution.
fredrik
Newbie
 
Posts: 0
Joined: Fri Oct 30, 2015 11:49 am

Re: TC-08 - Voltage measuring

Postby Hitesh » Wed Nov 04, 2015 10:31 am

Hi fredrik,

Try ensuring that the computer and terminal boards are using a common ground reference.

Are the thermocouples touching any ceramic surfaces at high temperatures or metal surfaces?

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2429
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: TC-08 - Voltage measuring

Postby fredrik » Thu Nov 12, 2015 7:46 am

Hi Hatesh. Thanks for answering

I have tried that but it doesn't help. Below is the result of some of the measurements I did when trying to fix this. I will look into this more tomorrow, and it would be great with some advice.

With no earthing I get the following readings when both terminal boards are insterted in the logger:
condensing: 11,9 mV
evaporating: 4,76 mV

with only the condensing inserted:
condensing: 10,5 mV

with only evaporating inserted:
evaporating: 4,22 mV

only condensing with earting of the terminal
condensing: 24mV

Regards
Fredrik
fredrik
Newbie
 
Posts: 0
Joined: Fri Oct 30, 2015 11:49 am

Re: TC-08 - Voltage measuring

Postby Hitesh » Fri Nov 13, 2015 11:37 am

Hi Fredrik,

Please ensure that the voltages being input to the TC-08 after the scale-down by the resistors does not exceed the Common Mode voltage range (+/- 7.5V).

If you could provide a diagram or photograph showing the connections to the terminal board and where they connect to, that might be helpful.

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2429
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: TC-08 - Voltage measuring

Postby fredrik » Tue Nov 17, 2015 1:44 pm

Hi again

Problem solved. It was correct to connect the terminal boards to earth. We had done it wrong previously and I got confused.
fredrik
Newbie
 
Posts: 0
Joined: Fri Oct 30, 2015 11:49 am

Re: TC-08 - Voltage measuring

Postby Hitesh » Tue Nov 17, 2015 5:11 pm

Hi Fredrik,

Thanks for the update - good to hear it is working :D

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2429
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to USB PC Data Loggers

Who is online

Users browsing this forum: No registered users and 0 guests