Test and Measurement Forum

Two channel simultaneous data acquisition

Post your LabVIEW discussions here

Two channel simultaneous data acquisition

Postby bijeesh » Fri Mar 13, 2015 8:47 pm

Hi,
I want to use picoscope with labview for my experiment. I need to take data simultaneously from two channels A and B. Is it possible with picoscope 3207B. I have just gone through the examples an I found it uses only one channel. Kindly help me in adding the second channel also in labview software.

Thank You
bijeesh
Newbie
 
Posts: 0
Joined: Fri Mar 13, 2015 8:39 pm

Re: Two channel simultaneous data acquisition

Postby AndrewA » Mon Mar 16, 2015 4:54 pm

Yes you acquire simultaneously data for both channels in labview-
In the 3000aExampleBlock.vi- for example press ctrl-E for block diagram.
Find the unconnected control wire for Channel B control, its next to Channel A control on the ‘PS3000 Settings’ block.
Right select ‘create ‘ sub menu ‘Indicator’ (You can then right on the Indicator and select ‘view as icon’ if needed)
Double click on the ‘Indicator’ icon so it will appear in the Front panel view.
Go back to the Block diagram window and select channel A Buffer and the graph ‘Indicator’ copy and paste these.
Rename graph copy to Channel B, click on the ‘Channel A Buffer’ copy and select Channel B from the drop down.
Connect a wire from ‘Channel B Buffer' to same wire going between ‘PS3000 Block’ and ‘channel A Buffer’.

For the 3207B-
Max. Analogue bandwidth is 250 MHz at -3dB,
Max. sample rate for two channels enabled is 500MS/s
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: Two channel simultaneous data acquisition

Postby bijeesh » Mon Mar 16, 2015 6:05 pm

Thanks for your help.

I was trying to run the program but it shows some warnings as shown below. But I think this warnings are fine. But When I am trying to run the program It shows error as some Vi is not executable. The error image is attached here. Kindly help me to solve this issue.

Thank you

''C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aClose.vi (PicoScope3000aClose.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000aExampleStreaming.vi (PicoScope3000aExampleStreaming.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000aWrap.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000aWrap.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aGetStreamingValues.vi (PicoScope3000aGetStreamingValues.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000aWrap.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000aWrap.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aOpen.vi (PicoScope3000aOpen.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aPowerSource.vi (PicoScope3000aPowerSource.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aSettings.vi (PicoScope3000aSettings.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aStartStreaming.vi (PicoScope3000aStartStreaming.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000aWrap.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000aWrap.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aUnitInfo.vi (PicoScope3000aUnitInfo.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000a.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000a.dll".
C:\Users\Lab\Desktop\PS3000Asdk_r10_5_2_1\LabVIEW\PicoScope3000a.llb\PicoScope3000aWrap.vi (PicoScope3000aWrap.vi)
- The shared library expected to be at "..\..\Program Files (x86)\National Instruments\LabVIEW 2013\resource\ps3000aWrap.dll" was loaded from "C:\Program Files (x86)\National Instruments\LabVIEW 2014\resource\ps3000aWrap.dll".
Attachments
warn1.png
error1
bijeesh
Newbie
 
Posts: 0
Joined: Fri Mar 13, 2015 8:39 pm

Re: Two channel simultaneous data acquisition

Postby bijeesh » Mon Mar 16, 2015 6:09 pm

Í think the error file has not loaded properly. I am uploading it here.
Attachments
warn3.png
bijeesh
Newbie
 
Posts: 0
Joined: Fri Mar 13, 2015 8:39 pm

Re: Two channel simultaneous data acquisition

Postby AndrewA » Tue Mar 17, 2015 9:02 am

Have you copied the wrapper dll into the resource directory in your LabVIEW installation directory?
i.e.
C:\Program Files\National Instruments\LabVIEW 2013\resource

Or LabVIEW has not made the connection and you will need to open each ‘call library function block’ See-(https://www.picotech.com/support/topic12601.html section 6 & 7).

Regards Andrew
Technical Specialist
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm

Re: Two channel simultaneous data acquisition

Postby bijeesh » Tue Mar 17, 2015 6:20 pm

Yes I have copied the files in the specified folder. But today I have downloaded the file again and tried, No it is working

Is it possible to keep maximum sampling rate and collect data for one second continuously using block mode. Ie, keep the sampling rate at 500 MS/s so that the total number of data to be collected in second will be 500000000. I tried doing this by using block mode but It shows some memory full error(not enough memory). And I need to take data from two channels. Is it possible to do with block mode?

thank you
Bijeesh
bijeesh
Newbie
 
Posts: 0
Joined: Fri Mar 13, 2015 8:39 pm

Re: Two channel simultaneous data acquisition

Postby AndrewA » Thu Mar 19, 2015 1:09 pm

Have you checked each ‘call library function block’?
Are you using 64 or 32 bit LabVIEW?

The answer to your acquisition with 3207B is no-
The device can sample at a max of 500MS/s, so in block mode this uses uses the devices internal memory of 512M.

So; (512M memory/2 channels) / 500MS/s = 0.512s = 512ms

Regards Andrew
Technical Specialist
Regards Andrew
Technical Specialist
AndrewA
Zen Master
Zen Master
 
Posts: 178
Joined: Tue Oct 21, 2014 3:07 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests