Test and Measurement Forum

data loss in capture buffer due to connection error

Forum for discussing PicoScope version 6 (non-automotive version)

data loss in capture buffer due to connection error

Postby mamaschew » Fri Mar 13, 2015 10:57 am

When I capture a measurement with the picoscope software (without saving) and pull off the usb connection, then the software tries to reconnect the device and discards the captured data. Is there a possibility to prevent this behaviour or to restore the "last" captured signals? Of course there is no need to pull off the usb cable during a measurement, but sometimes there are situations where the connection suddenly gets lost (for example due to a pc error or the contact loss due to mechanical vibrations).
Posts: 0
Joined: Fri Mar 13, 2015 10:27 am

Re: data loss in capture buffer due to connection error

Postby Hitesh » Mon Mar 23, 2015 12:49 pm

Hi mamaschew,

Our Development Team are aware of this issue so I have added your comments to an existing bug report.

In streaming mode captures, the data is in PC memory so it should be possible to save this to disk in the event of losing the connection. In block/rapid block mode captures, the data is still on the device, but the software shows an aggregated view (min/max data values) so it is not possible to recover the raw data.


Technical Specialist
Pico Technology
Site Admin
Site Admin
Posts: 2026
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests