Program giving 0 for picoscope 3205

Post any questions you may have about our current range of oscilloscopes
Post Reply
d_olivenza
Newbie
Posts: 0
Joined: Mon Feb 02, 2015 11:35 am

Program giving 0 for picoscope 3205

Post by d_olivenza » Wed Feb 04, 2015 11:52 am

Hi,

I am using the program attatched, which is a modification of one given in the SDK. It is not working properly and I don't know why. I am a beginner with LabView. I appreciate your answers.

Kind regards
Attachments
ps3000_runStream3.vi
(47.25 KiB) Downloaded 107 times

Karunen
Advanced User
Advanced User
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Program giving 0 for picoscope 3205

Post by Karunen » Mon Feb 09, 2015 3:57 pm

Hi,

Unfortunately the 3204, 3205 & 3206 does not have fast streaming.

This means ps3000_run_streaming_ns function will always return 0.

Kind Regards,
Karunen

Technical Specialist
Pico Technology

d_olivenza
Newbie
Posts: 0
Joined: Mon Feb 02, 2015 11:35 am

Re: Program giving 0 for picoscope 3205

Post by d_olivenza » Tue Feb 10, 2015 8:55 am

Hi,

Thanks for your help. So, using this digital oscilloscope, what function can I use to measure a signal of hundreds of microsecs?

Kind regards

Karunen
Advanced User
Advanced User
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Program giving 0 for picoscope 3205

Post by Karunen » Wed Feb 11, 2015 12:24 pm

Hi,

Unfortunately with this device you will need to use block mode.

This means you are storing information to the device's internal memory which you can pull out once the device has finished collecting.

Kind Regards,
Karunen

Technical Specialist
Pico Technology

Post Reply