Test and Measurement Forum

Triggering problems with picoscope 3205 (LabView)

Post any questions you may have about our current range of oscilloscopes

Triggering problems with picoscope 3205 (LabView)

Postby d_olivenza » Mon Feb 02, 2015 11:43 am

Hi.
I have a problem trying to trigger my signal in order to see it clearly. My target is to measure a periodic signal of hundreds of microseconds. I have used the program ps3000_runStream and changed all constants to control. But the point is that some of them doesn't work properly and I am a begginner with LabView. I have tried using Picoscope 6 and all works, but I need to have the same in LabView because I am going to add some components to measure at the same time. My program is attached to this message.
Thanks
Attachments
ps3000_runStream.vi
(45.66 KiB) Downloaded 98 times
d_olivenza
Newbie
 
Posts: 0
Joined: Mon Feb 02, 2015 11:35 am

Re: Triggering problems with picoscope 3205 (LabView)

Postby Karunen » Tue Feb 03, 2015 10:29 am

Hi,

Can you explain what you mean by some of them did not work properly?

Do you know which driver version you are using?

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Triggering problems with picoscope 3205 (LabView)

Postby d_olivenza » Tue Feb 03, 2015 10:38 am

Hi,

Well, the trigger controls don't work at all, neither do the ETS ones. The channel controls do something but not what they should. For instance, when ENABLED is activated or deactivated the only difference is a change in the amplitude, but the channel is still being displayed. I downloaded the SDK this month and it is the version 10.5.2.

Best regards
d_olivenza
Newbie
 
Posts: 0
Joined: Mon Feb 02, 2015 11:35 am

Re: Triggering problems with picoscope 3205 (LabView)

Postby Karunen » Wed Feb 04, 2015 9:35 am

Hi,

When using the LabVIEW example I was able to get the trigger to work as expected.

Please note when the trigger is not enabled it will store data as fast as soon as it can.
While when the trigger is enabled then only when the trigger event occurs will it store data.

Please contact us at support@picotech.com to discuss further.

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Triggering problems with picoscope 3205 (LabView)

Postby d_olivenza » Wed Feb 04, 2015 10:03 am

Hi,

Did you use the example that I attatched or the one from the web?

Regards
d_olivenza
Newbie
 
Posts: 0
Joined: Mon Feb 02, 2015 11:35 am

Re: Triggering problems with picoscope 3205 (LabView)

Postby Karunen » Wed Feb 04, 2015 3:24 pm

Hi,

Please accept my apologies I was look at our web example.

Having a another look at your example I can replicate the error of getting data when channels are not enabled.

But unfortunately in this streaming mode you cannot use triggering.

https://www.picotech.com/download/manuals/ps3000pg-en-4.pdf

On page 9 it states "Does not support triggering"

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests