Test and Measurement Forum

Matlab getting an error when trying to set bandwidth filter

Post your MATLAB discussions here

Matlab getting an error when trying to set bandwidth filter

Postby giltech » Tue Nov 25, 2014 4:53 pm

This function worked correctly on r10_4_3_5 of SDK, but I wanted to use with 64 bit Matlab so updated to r10_5_1_1

The rest of my capture script works aside from this setting, and if I comment it out I can run fine.

Error occurs in both 32 bit and 64 bit Matlab with new SDK

I'm running a picoscope 3406B


Code: Select all
invoke(obj,'ps3000aSetBandwidthFilter',0)
Error using privateExecuteMCode (line 44)
There is no 'variant' property for device objects.

Error in instrgate (line 20)
   [varargout{1:nout}] = feval(varargin{:});

Error in icdevice/invoke (line 70)
        output = instrgate('privateExecuteMCode', code, obj, varargin,
        nargout);
giltech
Newbie
 
Posts: 0
Joined: Tue Nov 25, 2014 4:46 pm

Re: Matlab getting an error when trying to set bandwidth fil

Postby Hitesh » Tue Nov 25, 2014 5:31 pm

Hi giltech,

It appears that there is an error in the Instrument Driver file - could you please e-mail support@picotech.com and we can send you an updated Instrument Driver file.

It will also be uploaded to the MATLAB File Exchange page.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to MATLAB

Who is online

Users browsing this forum: No registered users and 2 guests