Test and Measurement Forum

Running picoscope 6.10.1 with homebrew-installed mono

Discussion forum for the new Picoscope Mac software

Running picoscope 6.10.1 with homebrew-installed mono

Postby vivekgani » Thu Nov 13, 2014 10:18 pm

Hey, I'm trying to get this to run but using my mono 3.8.0 installation done via homebrew (http://brew.sh) instead of installing mono manually.

When opening PicoScope 6.10.1 it doesn't seem to detect the installation. I have already tried re-linking mono within homebrew, but still get the message. Just FYI, overall excited about the prospect of buying a usb scope that works with the mac.
vivekgani
Newbie
 
Posts: 0
Joined: Thu Nov 13, 2014 10:11 pm

Re: Running picoscope 6.10.1 with homebrew-installed mono

Postby mario_ » Fri Nov 14, 2014 8:39 am

Hi Vivek,

I am assuming that mono installation ended up in a different location than normal mono MRE installer would put itself to (/Library/Frameworks/Mono.framework).
In the PicoScope6 installation you may want to edit 'picoscope' script (located under Contents/MacOS) and adjust DYLD_FALBACK_LIBRARY_PATH entry in the export. Also verify that 'mono' command is available in the shell.

Mario
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Re: Running picoscope 6.10.1 with homebrew-installed mono

Postby nikolaus » Mon Nov 23, 2015 3:45 pm

For anyone else coming here: the new version of the PicoScope app can detect the Homebrew Mono installation. However, Homebrew Mono doesn't come with Gtk-Sharp, which PicoScope uses for its GUI. I recommend for now using the official Mono installer rather than the Homebrew formula.
nikolaus
Newbie
 
Posts: 0
Joined: Mon Nov 23, 2015 3:43 pm


Return to PicoScope for Mac

Who is online

Users browsing this forum: No registered users and 0 guests