Test and Measurement Forum

Software cannot find DrDaq - yet it works fine on old PC?

Post general discussions on using our drivers to write your own software here

Software cannot find DrDaq - yet it works fine on old PC?

Postby Guest » Thu Mar 17, 2005 8:59 am

We have a Visual Basic application which we use to read from the DrDaq external port (we are counting objects going past a sensor).

It has worked fine on a Windows 98 PC, but the PC was knackered so we have replaced it with a Windows XP PC.

The software will not find the DrDaq device! Even the supplied "drdaq32.vbp" sample project will not find it.

Is there anything special we need to do? It's a Windows XP PC, with one parallel port (which works). We have installed the latest Pico drivers via the webdrdaq_r3_00.exe download from yiour website.

Have we missed anything?


Heeeeelllllppppppp!!!!!!!!!!!!!!!!!!!! :lol:

Many thanks,



Jim Willsher
Guest
 

Postby Sarah » Thu Mar 17, 2005 9:33 am

Hi Jim

Thank you for your post, I am sorry to hear that you have been seeing problems.

I suspect that the problem you are seeing may be related to the mode of the parallel port. Check and ensure that it is NOT set to ECP, EPP or Bidirectional. Instead it should be set to either:

SPP, Normal, Unidirectional, Output Only.

Let me know if that helps.

Best Regards
Sarah
 

Postby Guest » Thu Mar 17, 2005 11:15 am

Hi Sarah,

Many thanks for your extremely fast and useful reply! I wish all companies were the same!

The counter seems to have "settled down" a bit, insofar as it now gives negative readings when not triggered, and positive readings when triggered. it used to give a reliable 0 or 100.

I'm not on-site but I'll get somebody to check the BIOS settings and restart it, a nd I'll report back.

Thank you so much!



Jim
Guest
 

Postby Guest » Thu Mar 17, 2005 10:07 pm

Unfortunately we're no further forward. We changed the parallel port to "normal" and then we got "pico.sys not found" messages. I've reinstalled the drivers and restarted and we're back to getting the funny readings.

There does seem to be some consistency. many readings are negative whilst the occasional reading is positive. Under the old drivers the readings were exactly 0 or exactly 100.

Any ideas?

Many thanks, Jim
Guest
 

Postby Sarah » Fri Mar 18, 2005 9:38 am

Hi Jim

Thank you for your post, I am sorry to hear that this didn't help.

Could you send us a file showing these readings? Send it to tech@picotech.com and mark it for my attention - also remember to include a brief outline of the issue or a link to this thread to remind me of the history.

If you find the old drivers worked better then I will be able to send you the older ones via email. Firstly though I would like to look at an example of what you are seeing.

Best Regards
Sarah
 


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests