Test and Measurement Forum

PicoScope 3000 Datastreaming to Labview > 1MS

Post your LabVIEW discussions here

PicoScope 3000 Datastreaming to Labview > 1MS

Postby JosefM » Thu Oct 23, 2014 4:43 pm

Hi,

can you please help me with this issue? I got the vi for Datastreaming PicoScope3000aExampleStreaming.vi and the
PicoScope 3206B.

The sample rate is a U32 for "Sample Rate in Microseconds". My task is to implement a 5MS measurement.
How can i do that now? Is there another vi without limitation to 1MS? According to the datasheet, a datastreaming up to 10MS/s is possible.

Thank you very much,
Josef
JosefM
Newbie
 
Posts: 0
Joined: Wed Oct 15, 2014 5:07 pm

Re: PicoScope 3000 Datastreaming to Labview > 1MS

Postby Karunen » Mon Oct 27, 2014 11:26 am

Hi Josef,

In the SDK R10.5.0.32 the PicoScope3000aExampleStreaming.vi you should be able to select if the sample interval is specified in ns or us.

Please download the latest SDK from http://www.picotech.com/software.html

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: PicoScope 3000 Datastreaming to Labview > 1MS

Postby JosefM » Wed Nov 05, 2014 10:40 pm

Thank you, this is great!

I noticed some differences in the code and now I am a bit confused. Could you answer me 2 things please?

- What is an MSO Device? (MSO Streaming VI?)
- What does the Wrapper do? Wrap VI / wrap dll ?

thanks again!
JosefM
Newbie
 
Posts: 0
Joined: Wed Oct 15, 2014 5:07 pm

Re: PicoScope 3000 Datastreaming to Labview > 1MS

Postby Karunen » Thu Nov 06, 2014 9:54 am

Hi Josef,

The 3000 series has a range of Mixed Signal Oscilloscopes (MSO)

http://www.picotech.com/usb3-oscilloscope-logic-analyzer.html

These device have 2/4 analogue channels and 16 digital channels.

Certain programming languages such as LabVIEW cannot support C style callbacks, which streaming requires to avoid data corruption during capture.
The wrapper dll contains the callback and some set up function to make streaming easier to use.

Please have a look at http://www.picotech.com/support/topic14301.html

Hopefully this clears up some confusion.

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: PicoScope 3000 Datastreaming to Labview > 1MS

Postby JosefM » Tue Nov 11, 2014 5:36 pm

Alright, thank you! Yes i understand this part now.

But can you please help me with an error?

For the ExampleStreaming VI, using any set of parameters (also the default parameters), i get the Error 5013.
Message: "Possible Reasons: PICO_INVALID_PARAMETER"

The Error appears after the last dll Function Call within PicoScope3000aStartStreaming.vi
--> Pico Status "ps300aRunStreaming".

Im using the PicoScope 3206B.

Thanks in advance!
JosefM
Newbie
 
Posts: 0
Joined: Wed Oct 15, 2014 5:07 pm

Re: PicoScope 3000 Datastreaming to Labview > 1MS

Postby Karunen » Thu Nov 13, 2014 3:34 pm

Hi Josef,

It looks like the example is incorrect I am passing time unit when I should be passing down sample ratio.

If you email support@picotech.com I can send you the .llb file that has the correction.

Kind Regards,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests