Test and Measurement Forum

I2C 7 bits or 8 bits adress problem

Forum for discussing PicoScope version 6 (non-automotive version)

I2C 7 bits or 8 bits adress problem

Postby modelvincent » Tue Sep 30, 2014 10:10 am

Hello, I'm working with the last release of picoscope (6.9.16.17) with a 3204A and I have an issue in I2C decoding.

The data is correctly decoded but the adress is only decoded in 7 bits mode, but in my case I need an 8 bits decoding.

On my previous release I could select between One mode or the other but in this new release, I can found this option?

Where is this option?

Thanks in advance,

Vincent
modelvincent
Newbie
 
Posts: 0
Joined: Tue Sep 30, 2014 10:07 am

Re: I2C 7 bits or 8 bits adress problem

Postby Hitesh » Thu Oct 02, 2014 10:29 am

Hi Vincent,

The option to select the address as 7-bit or 8-bit has been added to PicoScope 6.10.3 Beta:

I2C_Advanced_Decoder_Settings.PNG
I2C Advanced Decoder Settings dialog
I2C_Advanced_Decoder_Settings.PNG (8.45 KiB) Viewed 694 times


However, there is a known bug concerning the recognition of 8-bit addresses which is currently being investigated by our Development Team.

It is recommended to use 7-bit addressing which works well and recalculate your slave address based on the omission of the read/write bit.

Hope this helps.
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2063
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests