Test and Measurement Forum

Math channel flickering after Resolution enhancement

Forum for discussing PicoScope version 6 (non-automotive version)

Math channel flickering after Resolution enhancement

Postby Ax2 » Sun Aug 31, 2014 8:11 am

After increasing number of bits (either channel A or B), the match channel signal starts to flicker. I'm not even try to describe it by words, please see attached images. Flickering occurs between 100-200ms so it is easily able to take screenshot after few try.
Top signal: Channel B using 8 bits
Center signal: Channel B match LowPass
Bottom signal: Channel A using 8,5 bits
Attachments
Flicker2.jpg
Flicker1.jpg
Ax2
Newbie
 
Posts: 0
Joined: Tue Aug 26, 2014 5:32 pm

Re: Math channel flickering after Resolution enhancement

Postby Martyn » Mon Sep 01, 2014 6:23 pm

Can you post a psdata file, just use save current waveform to keep the size down, we can then look at what is happening. It may be to do with the way resolution enhancement works.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2339
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Math channel flickering after Resolution enhancement

Postby Ax2_ » Mon Sep 01, 2014 7:33 pm

Hello,

The requested file attached.

Ax.
Attachments
20140901-0001.psdata
(144.97 KiB) Downloaded 34 times
Ax2_
Newbie
 
Posts: 0
Joined: Mon Sep 01, 2014 6:23 am

Re: Math channel flickering after Resolution enhancement

Postby Martyn » Tue Sep 09, 2014 6:50 am

I can see the glitch whilst running, however if I stop the scope at the point of the glitch the waveform gets redrawn correctly. In other words the raw data is correct but the maths channel is occasionally using the wrong data for it's calculation.

I will pass this information onto the development team for investigation.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2339
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Math channel flickering after Resolution enhancement

Postby Ax2_ » Tue Sep 09, 2014 1:05 pm

Please check Match channel range setting-issue too. Checkbox "Override automatic range selection" does not work properly and when you want to change range, you need to change min/max values of math channel. If you deselect the checkbox, it will be reverted back to default settings.
Ax2_
Newbie
 
Posts: 0
Joined: Mon Sep 01, 2014 6:23 am


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests