Test and Measurement Forum

AWG not updating

Forum for discussing PicoScope version 6 (non-automotive version)

AWG not updating

Postby jswanson » Fri Aug 08, 2014 10:31 am

2205MSO with 6.9.14.16


I am using the AWG feature and find the waveform doesn't update is a change is only made on the 2nd half of the cycle.

Settings 50Hz 2V no offset Squarewave. AWG = 1024 samples and 1 cycle

If I make a change the the first half of the waveform and press apply I can see the waveform update immediately. However if I make a change only to the second half of the waveform the waveform doesn't update when I press apply.


Also: It would be great to be able to trigger from the AWG directly. I am trying to recreate spikes in data using the AWG and it is difficult to trigger from the resulting waveform.
jswanson
Active User
Active User
 
Posts: 14
Joined: Wed Apr 05, 2006 8:07 pm

Re: AWG not updating

Postby Martyn » Mon Aug 11, 2014 1:53 pm

A very unusual bug which also affects 2206/7/8 devices.

I have reported it to the development team for investigation.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: AWG not updating

Postby jswanson » Tue Aug 12, 2014 3:29 pm

Thanks Martyn,

Any possibility of triggering from the AWG or is this not possible due to hardware limitations?

Jeremy.
jswanson
Active User
Active User
 
Posts: 14
Joined: Wed Apr 05, 2006 8:07 pm

Re: AWG not updating

Postby Martyn » Tue Aug 12, 2014 8:08 pm

Can you explain exactly what you are looking to do ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: AWG not updating

Postby jswanson » Mon Aug 18, 2014 7:47 am

Hi Martyn,

I'm creating a sinewave input with noise spikes on it. I would like to trigger on the same point on the AWG output, but this is difficult because of the spikes. I was wondering if it is possible to trigger the scope from the start (or any point) of the AWG?

Jeremy.
jswanson
Active User
Active User
 
Posts: 14
Joined: Wed Apr 05, 2006 8:07 pm

Re: AWG not updating

Postby Martyn » Wed Aug 20, 2014 8:59 am

Can you post a psdata file showing the waveform, and AWG signal.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: AWG not updating

Postby jswanson » Mon Sep 15, 2014 3:56 pm

Hi Martyn,

I keep changing the waveform. It's a sinewave with a spike somewhere along it's length. I was wondering if it would be possible to trigger on a certain part of the AWG output. For example: if the AWG is 1024 long, trigger at an arbitrary sample of, say, 300.



Jeremy.
jswanson
Active User
Active User
 
Posts: 14
Joined: Wed Apr 05, 2006 8:07 pm

Re: AWG not updating

Postby Martyn » Mon Sep 29, 2014 7:34 am

I am not sure I understand what you are trying to achieve.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2355
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests