Picoscope 6 strange zoom error

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
yym
Newbie
Posts: 0
Joined: Mon Nov 19, 2012 7:39 pm

Picoscope 6 strange zoom error

Post by yym » Thu Aug 07, 2014 8:49 pm

I have found a strange behavior when viewing data zoomed in.
Sometimes (at different zoom levels) the analog and the digital traces are not aligned, they go in and out of alignment and I am not talking about small alignment errors, they are completely off, like alignment 'jumps' >50% front or back.
See attached pictures, the data was captured in singe shot mode, then viewed in different zoom levels
z2- zoom ok (included for reference)
z3,z5 -bad zoom, whach the cursors.
Also in z5 some strange stuff appears on the digital channels (there should be nothing there )
Pico SW version is: 6.6.50.3 HW 2205MSO

To me it seems a GUI bug since the captured data is correct only it is not displayed correctly at some zoom levels.
Attachments
zoomerror.zip
(237.27 KiB) Downloaded 79 times

Karunen
Advanced User
Advanced User
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Picoscope 6 strange zoom error

Post by Karunen » Fri Aug 08, 2014 11:22 am

Hi YYM,

Would you mind downloading and testing if the issue occurs with PicoScope R6.9.14?

You can download R6.9.14 at the moment from the link below

http://www.picotech.com/software.html

Step 1: Select your device

Step 2: Select PicoScope R6.9.14

Step 3: click on the download R6.9.14 button

Kind Regards,
Karunen

Technical Specialist
Pico Technology

yym
Newbie
Posts: 0
Joined: Mon Nov 19, 2012 7:39 pm

Re: Picoscope 6 strange zoom error

Post by yym » Fri Aug 08, 2014 4:00 pm

I would like to use the latest pico sw, but unfortunately the new version doesn't work with my hw.
See this post http://www.picotech.com/support/topic11541.html

So i have to use the older version (which still doesn't work properly, but has at least pulse width trigger on channel A(only))

In order to reproduce this usecase, i need pulse width trigger, otherwise the scope would trigger on 'garbage'

Karunen
Advanced User
Advanced User
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Picoscope 6 strange zoom error

Post by Karunen » Mon Aug 18, 2014 2:29 pm

Hi YYM,

The strange zoom error has been fixed in version 6.9,
but as you cannot use that version I will escalate the pulse trigger bug.

Kind Regards,
Kay
Karunen

Technical Specialist
Pico Technology

Post Reply