math channels

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
picoalex
Newbie
Posts: 0
Joined: Fri Jul 11, 2014 12:55 pm

math channels

Post by picoalex » Fri Jul 11, 2014 1:59 pm

Hi,
I have troubles when I have to insert a formula in a math channel section. A simple formula (A-0.1) return ERROR and freeze the process. All decimal costant return an error. I need to solve this problem 'cause I need to insert a Pressure Sensor characteristic.

What can I do?

Thanks
Attachments
PicoPrintScreen.JPG

bennog
Active User
Active User
Posts: 33
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands

Re: math channels

Post by bennog » Fri Jul 11, 2014 4:41 pm

Have you tried using a , in stead of a .

Otherwise setting the language to English and using a . works.
After saving the math formula you can set the language back to your own language.

Regards,
Benno

joejoe
Newbie
Posts: 0
Joined: Sat Jul 19, 2014 10:44 am

Re: math channels

Post by joejoe » Sat Jul 19, 2014 10:53 am

I have the same problem with a german notebook. I checked it with a . an a , . I changed the picosoftware to Englisch without a result.

regards

joejoe

bennog
Active User
Active User
Posts: 33
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands

Re: math channels

Post by bennog » Sun Jul 20, 2014 6:43 pm

Ok my fault, I thought this problem was solved about 1 year ago but it still exists.

You can solve this in Windows by changing the local number settings to . for decimal separator and , for thousand separator.
Number Settings Windows.png
I have marked the button and fields in Yellow you need to click and change (sorry it is dutch Win 7)

After you created the math formulas and saved them you can change it back to its original in Windows and still use the created formulas.

I checked both the beta and release version of Picoscope but they sit


Regards,
Benno

Hitesh
Site Admin
Site Admin
Posts: 2827
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: math channels

Post by Hitesh » Thu Jul 24, 2014 8:36 am

Hi All,

The Development Team are aware of this and I have added comments from this thread to the bug report.

For now, please use the method of changing the local number settings as described by bennog and save the maths channels. If you attempt to edit the saved files using the Maths Channel wizard with the number settings set to your normal settings, the error will occur.

Many thanks,
Hitesh

Technical Support Engineer

Post Reply