Test and Measurement Forum

Bug in persistence mode: spikes at the end of singal plot

Forum for discussing PicoScope version 6 (non-automotive version)

Bug in persistence mode: spikes at the end of singal plot

Postby Jenson » Tue Jun 10, 2014 8:04 am

Hi,

when i use the persistence mode to measure worst case latencies of an operating system (long time measurement over many hours) i sometimes get small peaks at the end of my plot (see attachment). They are less than a half of the amplitude of my measured signal and I can reproduce this behavior with different time bases. So i`m 100% sure that they don't belong to my original signal. It seems that this problem occurs only on measurements > 3 hours... Could you check that for me?

Thx
Jens Kaufmann
Attachments
preempt_RT-12.0_smp_cpuset_and_irq_affinity_optimized_24h.png
Jenson
Newbie
 
Posts: 0
Joined: Tue Jun 10, 2014 7:46 am

Re: Bug in persistence mode: spikes at the end of singal plo

Postby Karunen » Thu Jun 12, 2014 7:27 am

Hi Jens,

I am having trouble replicating the issue.

Could you tell me which device and which version of PicoScope you are using?

Thanks,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Bug in persistence mode: spikes at the end of singal plo

Postby Jenson » Fri Jul 25, 2014 2:01 pm

Hi Karunen,

sorry for the late reply...here the details oft my SW and HW versions:

Version: 6.7.28.7
Copyright © 1995-2013, Pico Technology Ltd

Modell: PicoScope 3206MSO
Seriennummer: CY050/005
USB-Version: 2,0
Kalibrierungsdatum: Donnerstag, 6. Juni 2013
Hardwareversion: 1
Treiberversion: 1.0.0.428
Firmwareversion: 1.3.3.0 / 0.6.8.0
Jenson
Newbie
 
Posts: 0
Joined: Tue Jun 10, 2014 7:46 am

Re: Bug in persistence mode: spikes at the end of singal plo

Postby Hitesh » Mon Jul 28, 2014 2:17 pm

Hi Jenson,

You appear to be using a relatively older version of PicoScope 6.

Please download and install the latest version of PicoScope 6 from our software download pages:

http://www.picotech.com/software.html

In step 1, select the PicoScope 3206MSO and in step 2, please select the option for the PicoScope 6 software.

Please post back here if the issue is still occurring.

Thanks,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 1 guest