Test and Measurement Forum

Not able to download linux software

Discussion forum for the new Picoscope Linux software

Not able to download linux software

Postby erickung » Wed May 21, 2014 5:49 pm


I just got 4224 and tried to download linux pico software using following instruction
I failed in the 3rd step with 403 error, and not able to locate the package in 4th step.
Any tips to help me isolate the root cause would be appreciated.
My machine is running ubuntu 12.04

1. Add repository to the updater
sudo bash -c 'echo "deb http://labs.picotech.com/debian/ picoscope main" > /etc/apt/sources.list.d/picoscope.list'
> It works for me, I'm able to see the file in that folder
2. Import public key
wget -O - http://labs.picotech.com/debian/dists/p ... se.gpg.key | sudo apt-key add -
> It works for me, and I can see the key shown in the list
3. Update package manager cache
sudo apt-get update
> I hits "403 Frobidden" error(following is the partial log and I comment out IP address only)
> But I'm able to use browser to access the link(for example, http://labs.picotech.com/debian/dists/p ... 4/Packages)

Ign http://labs.picotech.com picoscope Release.gpg
Ign http://labs.picotech.com picoscope Release
Err http://labs.picotech.com picoscope/main amd64 Packages
403 Forbidden [IP: ::...................]
Err http://labs.picotech.com picoscope/main i386 Packages
403 Forbidden [IP: ::....................]
W: Failed to fetch http://labs.picotech.com/debian/dists/p ... 4/Packages 403 Forbidden [IP: ::...................]

W: Failed to fetch http://labs.picotech.com/debian/dists/p ... 6/Packages 403 Forbidden [IP: ::...................]

E: Some index files failed to download. They have been ignored, or old ones used instead.
4. Install PicoScope
sudo apt-get install picoscope

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package picosope
Posts: 0
Joined: Wed May 21, 2014 5:13 pm

Re: Not able to download linux software

Postby mario_ » Tue May 27, 2014 12:38 pm

Hi erickung,

I've checked logs for the server and I don't see any occurrence for 403 errors for the repository. Key update using wget worked for you which may point here to configuration of apt. Maybe there is a proxy specified?

try this:

Code: Select all
apt-config dump | grep proxy

If the command returns anything, try searching it in /etc/apt directory:
Code: Select all
grep -nir proxy /etc/apt/

locate the file and remove proxy entries.

Otherwise - you have removed IP addresses from the output, it might have indicate to us whether your resolver works OK. labs.picotech.com should resolve to any of the following IPs:, If you have different results, look into your network configuration. (check contents of /etc/resolv.conf - if exists)

There is another - less likely to occur - explanation; if the problem has resolved itself. Your connection were made at the time where one of the bundled webservers was under maintenance.

Site Admin
Site Admin
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests