Picoscope 3425 connection

Post any questions you may have about our current range of oscilloscopes
Post Reply
michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Picoscope 3425 connection

Post by michaell » Mon May 19, 2014 5:49 am

Hi, I have a picoscope 3425 and it works well with my labtop. I recently tried to connect the scope to another computer with Window Embedded Standard SP1 64bit OS and I cannot get the driver installed successfully. The computer shows unknown device and I could not use Picoscope 6 software. Attached are the screenshots and I wonder if I can install the drive manually. Thank you very much.
Attachments
unknow device properties 3.jpg
unknow device properties 2.jpg
unknow device properties.jpg

Hitesh
Site Admin
Site Admin
Posts: 2793
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 3425 connection

Post by Hitesh » Tue May 20, 2014 3:39 pm

Hi michaell,

You can try running the DPInst.exe file located in the PicoScope 6 installation directory to see if the USB drivers can be installed.

Please navigate to:

C:\Program Files (x86)\Pico Technology\PicoScope6\system

where you will find the file.

The system directory is also available in the Software Development Kit for the device.

I hope this helps.
Hitesh

Technical Support Engineer

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Tue May 20, 2014 9:25 pm

Hi Hitesh,

I just tried DPInst.exe but it does not work. I Tried on two computers of the same type. one computer shows
Reinstall the drivers for this device. (Code 18)
and the other computer shows
This device is not configured correctly. (Code 1)

Is there any other methods I should try?

Thanks a lot.
Attachments
code.jpg
code 1

Hitesh
Site Admin
Site Admin
Posts: 2793
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 3425 connection

Post by Hitesh » Thu May 22, 2014 11:07 am

Hi michaell,

Could you please provide the following information:
  • Which version of PicoScope 6 are you installing?
  • Did the PicoScope 6 install complete successfully?
  • What are the Embedded PC specifications?
  • Are you using Administrator rights to install the software?
  • Are the PCs connected to the internet at the time of install?
Many thanks,
Hitesh

Technical Support Engineer

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Thu May 22, 2014 10:00 pm

Hi Hitesh,

-I installed 6.7.40.3 provided by the original cd. Just now, the program tried to update to 6.8.11.20 and after the update, I tried connecting the scope again and still not working.

-The picoscope 6 installed successfully. I can run the program but when I opened it, it say it cannot find the device.

-It is a Intel(R) Core(TM) i7-2710QE CPU @2.10GHz, 4GB ram, 64bit os. I attached a screenshot of the system spec

-yes I am using the administrator right.

--yes it is connected to internet.

Thanks a lot. :D
Attachments
pc spec.png

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Thu May 22, 2014 10:14 pm

Hi Hitesh,

* The picoscope version is 6.7.40.3 and just now, the program tried to update automatically to 6.8.11.20. After the update, I tried again and it still not working.

*The program installed successfully. I can run the program but it says cannot find device.

*It is an Intel Core i7-2710QE CPU 2.1GHz. 4GB ram, 64bit os, I attached a screenshot of the system

*Yes, I double checked and I am using Administrator right.

*Yes it was connecting to internet.

Thanks a lot.
Attachments
pc spec.png

Hitesh
Site Admin
Site Admin
Posts: 2793
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 3425 connection

Post by Hitesh » Fri May 23, 2014 10:33 am

Hi michaell,

Thank you for the information provided.

Does the device work if you plug it into the laptop after trying it with the embedded PC?

PicoScope Beta R6.9.5 is available to download from http://labs.picotech.com/.

There's no need to uninstall PicoScope 6.8.11.

Could you please try this version and see if this works?

Many thanks,
Hitesh

Technical Support Engineer

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Sun May 25, 2014 10:18 pm

Hi Hitesh,

The device work with the laptop after I tried with the embedded PC. I just tried R6.9.5 and it works. It was able to install driver successfully once I plug the scope into the usb port.

Many thanks

Michael

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Thu Jul 17, 2014 3:21 am

Hi Hitesh,

Just coming back to the installation of Picoscope 3425 into the embedded PC. I did successfully installed R6.9.5 into one PC and it works. I have 3 more identical computers and just now I tried to repeat the same thing and tried to get the scope connected but it didn't work.

I was installing the software first then plugged in the scope, then there is a window said driver is installed unsuccessfully.

Do you know what is the reason I cannot set up the scope at the other computers?

Thanks

Michael

Hitesh
Site Admin
Site Admin
Posts: 2793
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 3425 connection

Post by Hitesh » Thu Jul 17, 2014 10:44 am

Hi Michael,

PicoScope 6.9.12 is now available as the standard release.

Please could you run DPInst.exe on the PCs on which you are having the problem, and send the DPINST.log files which are located in the C:\Windows folder to support@picotech.com

Thanks,
Hitesh

Technical Support Engineer

michaell
Newbie
Posts: 0
Joined: Wed Feb 26, 2014 4:12 am

Re: Picoscope 3425 connection

Post by michaell » Thu Jul 17, 2014 10:56 pm

Thanks Hitesh,

Will send you the file.

Cheers

Michael

Post Reply