Test and Measurement Forum

Sampling rate setting problem on PS6 of 6403A

Forum for discussing PicoScope version 6 (non-automotive version)

Sampling rate setting problem on PS6 of 6403A

Postby Toni » Thu Mar 27, 2014 3:33 pm

Hi,

Is it possible to specify the number of samples (sampling rate) that can meet the requirement?

Though I was told by the software itself that the actual number of samples could be different from the value I set, I still want the PC scope can capture as many samples as I need.

For example, if I set 2 million samples over 2 seconds time period, ideally, the sampling rate should then be 1 MHz and I am suppose to get 2 million samples in a 2-second time duration. But the actual sampling rate is 995 kHz and the scope only has 1,990,050 number of samples. I tried to increase the number of samples slightly, but the scope can capture either less or more than 2 million points.

So my question is if I need exactly 2 million points in 2 seconds, what should I do with the setting?

Thanks very much in advance. Cheers.

Toni
Toni
Newbie
 
Posts: 0
Joined: Wed May 22, 2013 2:07 pm

Re: Sampling rate setting problem on PS6 of 6403A

Postby Martyn » Mon Mar 31, 2014 10:14 am

The number of samples you request and the time duration on the screen will define how the software will set the scope. This will be based upon the actual sample interval settings that the hardware can support. If you select View->ViewPorperties you will get a screen showing the actual settings.

If you need further information please post a psdata file, File->Save->SaveCurrentWaveform, and we can explain why the values have been chosen.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2339
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Sampling rate setting problem on PS6 of 6403A

Postby Toni » Mon Mar 31, 2014 2:09 pm

Thanks for your reply, Martyn. :D

I've attached the raw file and screen shot here.

So current software setting is 2 million samples over 2-second time duration as can be seen in the first screen shot. And the hardware can actually capture only 1,990,050 samples. If my post-processing algorithm needs captured data in very high precision, do you mean it is not possible to have exactly 2 million samples no matter how I set up the scope? :roll:

Another problem is that there is a trigger delay here as shown in the second screen shot. The signal is about 35 us before the diamond pointer(trigger point), is there a way to compensate for this and keep the delay to zero?

Thanks again!
Toni
Newbie
 
Posts: 0
Joined: Wed May 22, 2013 2:07 pm

Re: Sampling rate setting problem on PS6 of 6403A

Postby Martyn » Mon Apr 07, 2014 2:35 pm

Files received on our ticket system will continue the discussion there
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2339
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests