Test and Measurement Forum

Problems with ps5000aSetDeviceResolution (5444B device)

Post your LabVIEW discussions here

Problems with ps5000aSetDeviceResolution (5444B device)

Postby MikeNuke » Wed Feb 19, 2014 11:32 am

Hi!
I did changes in my labview software we use to acquire data in order to add the possibility of using also a 5444B device.

All the libraries and subVIs were substituted and everything works fine.

Since one of the best things with this device is the flexible resolution, I also added a subVI to manage it, and this is not working.
The ps5000aSetDeviceResolution call library reports a PICO_INVALID_HANDLE error (5012).

Since all the other libraries work, I don't understand what could be wrong with the handle. I can set the resolution at the beginning when I open the device, but changing it while running could be very useful...

I attach the not-working subVI.

Thanks!
Attachments
PicoSetResolution.vi
(20.41 KiB) Downloaded 100 times
MikeNuke
Politecnico di Milano
Department of Energy, Nuclear Engineering Division
MikeNuke
Newbie
 
Posts: 0
Joined: Thu Oct 31, 2013 1:49 pm

Re: Problems with ps5000aSetDeviceResolution (5444B device)

Postby Karunen » Wed Feb 19, 2014 1:03 pm

Hi Mike,

The issue is that you are calling handle as a pointer to value,
when you should be using just the value.

The pointer to the handle is only used when opening the device.

Thanks,
Karunen

Technical Specialist
Pico Technology
Karunen
Zen Master
Zen Master
 
Posts: 194
Joined: Thu Nov 21, 2013 9:22 am

Re: Problems with ps5000aSetDeviceResolution (5444B device)

Postby MikeNuke » Wed Feb 19, 2014 1:10 pm

Ok,
I should probably change my nick to MikeNoob.

Thank you, now it'is all working :)
MikeNuke
Politecnico di Milano
Department of Energy, Nuclear Engineering Division
MikeNuke
Newbie
 
Posts: 0
Joined: Thu Oct 31, 2013 1:49 pm


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests