Test and Measurement Forum

Frustrations with PICO Scope

Forum for discussing PicoScope version 6 (non-automotive version)

Frustrations with PICO Scope

Postby adeshere » Fri Feb 14, 2014 10:43 am


I have started to use your PICOScope 6 after many years of using 'actual' scopes.

Here is the list of the main issues i came across

How to add another channel ..
Once you know its obvious but i kept going to the menu 'Views->Channels' to select but there is nothing shown. Cant you just display all the channels in this list with a tick box which when ticked just enables the trace and sets it to auto ?

Cursors - You call them rulers
Little box in the corner is like playing 'Spot Wally' , please just add a menu option to display either horizontal or vertical rulers and when selected just place them towards the center of the screen so the user can see them.

Save as Image
The traces and rulers get saved as the image BUT the box showing the values of the cursors are not included !! bit pointless

I do like the kit, just need to sort out the frustrations for new users

Posts: 0
Joined: Fri Feb 14, 2014 10:36 am

Re: Frustrations with PICO Scope

Postby Martyn » Mon Feb 17, 2014 10:50 am

Thank you for the feedback.

We are currently looking at the user interface and so suggestions for improvements are very welcome, I will pass yours into the mix to add weight to similar requests that we have received.
Technical Specialist
Site Admin
Site Admin
Posts: 2313
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: beav700 and 0 guests