Test and Measurement Forum

PicoScope.GTK ERROR

Post your Linux discussions here

PicoScope.GTK ERROR

Postby isidre » Wed Feb 12, 2014 7:00 pm

Hi.

I installed via repository the new linux version of picoscope over my amd64 wheezy machine.

when I launch the picoscope from a terminal window I get the following exception message:

isidre@Kairos:~$ picoscope

Unhandled Exception: System.TypeLoadException: Could not load type 'System.Runtime.Versioning.TargetFrameworkAttribute' from assembly 'PicoScope.GTK'.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'System.Runtime.Versioning.TargetFrameworkAttribute' from assembly 'PicoScope.GTK'.

I think that it's some package dependency not solved.

Somebody can help me?

Thanks in advance.

Isidre
isidre
Newbie
 
Posts: 0
Joined: Wed Feb 12, 2014 6:53 pm

Re: PicoScope.GTK ERROR

Postby mario_ » Thu Feb 13, 2014 10:20 am

Hi Isidre,

It appear you may have a broken mono installation.

Unless you have tried this already, lets start by reinstalling it:
Code: Select all
sudo apt-get install --reinstall mono-runtime libmono-system-core4.0-cil libmono-system-management4.0-cil libmono-system-windows-forms4.0-cil libmono-windowsbase4.0-cil libgtk2.0-cil


Run this command in the console and observe if there any error messages reported.

Regards,
Mario
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 0 guests