Test and Measurement Forum

AWG Startup Sequence

Post any questions you may have about our current range of oscilloscopes

AWG Startup Sequence

Postby hmaarrfk » Fri Dec 06, 2013 6:27 am

Hello,

I'm trying to use the PS5244 as part of a larger experiment. Unfortunately, during the startup sequence of the scope, the AWG rails at -2V for half a second and this negative voltage cannot be handled by the rest of my setup. I imagine this would cause problems for other people as well.

The AWG rails seems to rail when a call to ps5000aOpen (or variants) is made as well as when one sets up the power supply.

I am using the PS5000Asdk_r10_5_0_28 version of the dll

I have a few ideas about how mitigate this problem using extra hardware. I was wondering if a firmware update could change the startup sequence so as to program the DDS before it is turned on? Is this a possibility?

Thank you for your help,

Mark
hmaarrfk
Newbie
 
Posts: 0
Joined: Sun Jun 24, 2012 11:41 pm

Re: AWG Startup Sequence

Postby Martyn » Tue Dec 10, 2013 12:57 pm

This issue has been raised with our development team, I will post back when I have an answer.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: AWG Startup Sequence

Postby hmaarrfk » Mon Feb 10, 2014 2:48 am

Hi Martyn,

Has there been any update on this issue?

Thanks for your help,

Mark
hmaarrfk
Newbie
 
Posts: 0
Joined: Sun Jun 24, 2012 11:41 pm

Re: AWG Startup Sequence

Postby Martyn » Mon Feb 10, 2014 10:03 am

This has been fixed in the driver and will be available for download in the next release of Picoscope/SDK. Please contact support@picotech.com if you need this sooner.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests