Display update in zoom 6.7.35.1

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
CoyoteDavid
Active User
Active User
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Display update in zoom 6.7.35.1

Post by CoyoteDavid » Wed Sep 18, 2013 6:01 pm

I just updated to version 6.7.35.1 for my 3406B. Now when I zoom in, display does not update the waveform when scrolling left or right if zoomed in. To recreate, do the following:

Trigger: Repeat, some channel with a probe, level 1 volt
Zoom in to some level (I was using x64).
Sweep rate is not important, for test set to 1 ms/div.
Get a waveform on the screen from a single event, easy to do by just touching the probe tip with your finger.
NOTE: Do not hit stop! The display will be static du to no triggers coming in.
Scroll the display left or right.

During the scroll, the waveform display that is scrolling into the window is blank.

If I hit the STOP button, then waveforms update OK. This problem occurs when the trigger is armed, and waiting for a new trace, and you are looking at an existing trace.

Martyn
Site Admin
Site Admin
Posts: 3331
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Display update in zoom 6.7.35.1

Post by Martyn » Tue Sep 24, 2013 6:19 am

As the trigger is armed the device is still running and collecting / waiting to collect data to the internal buffer of the scope. When you scroll left or right it is not possible to get the data from the previous buffer to display on the screen. This is the expected mode of operation and the display will only update when you stop the scope.
Martyn
Technical Support Manager

Post Reply