Test and Measurement Forum

Line Thickness in version 6.7.21.2

Forum for discussing PicoScope version 6 (non-automotive version)

Line Thickness in version 6.7.21.2

Postby CoyoteDavid » Wed Jun 05, 2013 12:03 am

I just updated to version 6.7.21.2 and can no longer set the line thickness. I select Tools->Preferences->Colors then try setting Line Thickness. No matter what size I set (1, 2, 3 or 4 pt), the display always shows using the 1 pt line thickness. Is there some other way to set thickness? Am I setting it wrong? It used to work several versions ago, but hasn't worked for the last few updates.

I use Windows7 on a Core-I7 Asus desktop.
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Re: Line Thickness in version 6.7.21.2

Postby Martyn » Wed Jun 05, 2013 8:03 am

I have tested here and it appears to be working for me.

Which line thickness are you trying to adjust ? Rulers (new addition), Channel, or Grid lines ?
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2287
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Line Thickness in version 6.7.21.2

Postby CoyoteDavid » Thu Jun 06, 2013 5:51 am

I am trying to set the Channel thickness. I tried the Rulers and Grid lines, and they work. But, what ever I set the Channel thickness to, it always uses the thin lines like thickness 1.
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Re: Line Thickness in version 6.7.21.2

Postby Martyn » Thu Jun 06, 2013 6:10 am

Can you post a psdata file, save current waveform as, with the line thickness set to 3 but drawing as 1. It's a very strange issue that we can't reproduce.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2287
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Line Thickness in version 6.7.21.2

Postby CoyoteDavid » Thu Jun 06, 2013 2:11 pm

I have posted 2 files, one with thickness 3 and one with thickness 4. On further investigation, it appears that the traces are being thickened in the time axis (X dimension) only (see "Thickness_4_sin.psdata"). This makes for some strange looking effects on waveforms, as the thickness changes with the slope of the line. The other file, "Thiskness_3_thin.psdata", was taken with no signal applied, so when the trace is thickened in the time axis only, it has no effect.
Attachments
Thickness_4_sin.psdata
This file has thickness set to 4, channel A only, sin wave input.
(14.84 KiB) Downloaded 71 times
Thickness_3_thin.psdata
This file has the thickness set to 3 with channel A only. No signal is applied.
(51.28 KiB) Downloaded 76 times
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Re: Line Thickness in version 6.7.21.2

Postby Martyn » Mon Jun 17, 2013 9:49 am

Just tried with 6.7.28 (RC) and they appear to be working for me.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2287
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Line Thickness in version 6.7.21.2

Postby CoyoteDavid » Mon Jun 17, 2013 5:48 pm

I just loaded 6.7.27, then 6.7.28, and the problem still exists. I set it to a thickness of 4 pt. and it only thickens in the time axis. Makes for some rather odd effects, as the more vertical traces are thick, but the horizontal parts are very thin, quite obviously 1 pt.

I attached a .psdata file showing that issue, as well as another display issue. Channel C has a 1 kHz sine wave, with a 10 kHz filter applied to make it quiet. The line thickness is set to 4 pt. Notice how it is thin at the top. If you expand it shows easily. Also, the discontinuity just off the top and bottom of the sine wave is a strange effect of the display. If you go into the Tools-->Preferences-->Colors and swap between 4 pt and 1 pt, you can see the weird effects.
Attachments
Thickness_4_sin_v2_7_28.psdata
1 kHz sin wave, V6.7.28 (RC), showing line thickness in time axis only, and discontinuity in waveform.
(493.27 KiB) Downloaded 78 times
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Re: Line Thickness in version 6.7.21.2

Postby Martyn » Thu Jul 18, 2013 8:59 am

I have still had difficulties replicating this so I have posted it to the development team for comment
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2287
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests