Test and Measurement Forum

VI hepl content issue.

Post your LabVIEW discussions here

VI hepl content issue.

Postby neevedit » Wed May 22, 2013 9:33 am

Hi,

I was trying to measure in-cylinder pressure using Picoscope 2206 and program it using LabVIEW. My problem is that when I look at the sub VI provided by Picotech drivers and search for help content in Labview for Picoscope sub VI I do not get any type of help content. I mean to say there is no description for these VI. For example when I want to set sample clock for the program I do not know which sub VI to use because there is no help description. Hence I am attaching my Labview program and can someone please tell me which sub VI to use at which place (especially which VI in place of sample clock). I am also placing a picoscope sub VI so that you can see that there is no help content for it.
Pardon me for such a long post.

Regards,

Neevedit Singh.
Attachments
Untitled 1 - Copy.vi
(100.94 KiB) Downloaded 97 times
neevedit
Newbie
 
Posts: 0
Joined: Wed May 22, 2013 9:09 am

Re: VI hepl content issue.

Postby Hitesh » Wed May 22, 2013 2:12 pm

Hi Neevedit,

The LabVIEW vi files that we provide in the SDK do not have associated Help information in the vi files themselves.

Please refer to the Programmer's Guide for devices using the 2000a driver:

http://www.picotech.com/document/pdf/ps2000apg.en-3.pdf

Section 2.12.3 provides some information on the sub-vi files that are provided in the PicoScope2000a.llb file.

Our examples show how to use the sub-vi files (which in turn call functions from our shared library) in order to acquire data.The Programmer's Guide also provides information on the sequence of library function calls to acquire data.

I hope this helps.
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2009
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: VI hepl content issue.

Postby neevedit » Wed May 29, 2013 2:27 pm

Dear Hitesh,

Thanks for the help.
For other Sub VI I figured out but could you please tell me what is the corresponding VI for sample clock.
I can make guesses but when I get stuck up its just waste of time.

Regards,

Neevedit Singh.
neevedit
Newbie
 
Posts: 0
Joined: Wed May 22, 2013 9:09 am

Re: VI hepl content issue.

Postby Hitesh » Wed May 29, 2013 4:26 pm

Hi Neevedit,

By sample clock are you referring to the sampling interval?

If so, in the Programmer's Guide, please refer to section 8 (Timebases) - you need to calculate the index required using the formulae and then set that in the front panel. If you are using the streaming example, then set the interval in microseconds.

I hope this helps.
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2009
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests