Test and Measurement Forum

Picoscope 2205 MSO can not get the level 0V at channel B

Post any questions you may have about our current range of oscilloscopes

Picoscope 2205 MSO can not get the level 0V at channel B

Postby khanhtanvn88 » Mon Mar 25, 2013 2:00 am

My oscilloscope has 2 channels, channel A and channel B. When i connect 2 probes in the channels and use them simultaneously, i see just the channel A can get the level 0V very well, but the channel B always remains nearly -0.6V. How can i correct the level of channel B to get the 0V. Please help me to do that. Thank you very much!
Attachments
Picoscope 2205 MSO.psdata
(15.22 KiB) Downloaded 110 times
khanhtanvn88
Newbie
 
Posts: 0
Joined: Thu Mar 21, 2013 2:03 pm

Re: Picoscope 2205 MSO can not get the level 0V at channel B

Postby Martyn » Mon Mar 25, 2013 7:16 am

Where have you connected the ground clip of each probe ?
Are you connected to a desktop/laptop PC ? If laptop is it on mains power or battery ?
Are you using the blue Pico USB cable ?
Are the levels the same with nothing connected ?

Can you post the text from Help->About in the Picoscope software so that we can check the driver versions.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2340
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picoscope 2205 MSO can not get the level 0V at channel B

Postby khanhtanvn88 » Tue Mar 26, 2013 4:33 am

Thank you for reply me! I remember that when i buy the Picoscope, i have checked it and both of the channels got the 0V level very well. They displayed coincidentally very well, but i have gone wrong at channel B recently.
1/ I did both ways. The frist, I connect 2 ground clips at the same position 0V in the PCB ( I want to measure the scope at two positions in this board), but the result when i did not touch the pins of the two to anything was like the file i have posted. The second, i connected 2 probes to my picoscope, i let them staying freely (Did not connect anything to anything), the result shows the same .
2/ I use my Picoscope with Laptop.
3/ Actually, i set aside the genuine Picoscope USB Cable and using another same type.
4/ The levels are the same with nothing connected.

I have posted the text From Help -> About .... in word format. Please help me to solve this problem. Thank you so much!
Attachments
Picoscope 2205 MSO Data.doc
(305.5 KiB) Downloaded 80 times
khanhtanvn88
Newbie
 
Posts: 0
Joined: Thu Mar 21, 2013 2:03 pm

Re: Picoscope 2205 MSO can not get the level 0V at channel B

Postby Martyn » Tue Mar 26, 2013 8:48 am

Please see the following thread http://www.picotech.com/support/topic12019.html and follow the instructions to install the old driver which hopefully should fix your issue.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2340
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picoscope 2205 MSO can not get the level 0V at channel B

Postby khanhtanvn88 » Tue Mar 26, 2013 4:03 pm

I have fixed the problem. Thank you so much Mr Martyn.
khanhtanvn88
Newbie
 
Posts: 0
Joined: Thu Mar 21, 2013 2:03 pm


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests