Test and Measurement Forum

Using PT-104 on multiple laptop at the same time

Post general discussions on using our drivers to write your own software here

Using PT-104 on multiple laptop at the same time

Postby junedfird » Sun Mar 03, 2013 9:32 am

Hi MArtyn/Peter,

Can I use PT-104 on multiple laptops at the same time?

I mean, on one laptop with USB and on the other with Cross over cable.

Secondly, when using PT-104 with cross over cable, the software fails to detect the PT-104 unit. What could be the reason?

Thanks!

Juned
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby Martyn » Mon Mar 04, 2013 7:11 am

I have connected with USB and Ethernet from one PC before, never tried from two different machines I would suggest just trying it.

For the second question make sure that the PC and PT104 are on their own private subnet, try pinging the unit first to verify ethernet connectivity, and if you are using your own application make sure that you use both ipaddress:port and the serial number when using the open unit command.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Tue Mar 26, 2013 12:04 pm

Martyn,

I am trying to connect with USB and Ethernet both at the same time on the same laptop, but to no avail.

I am even trying to connect only with ethernet cable, but to no avail. The instrument is not getting detected.

I went into Ehternet settings, and entered the IP address as 192.168.1.70 and port as 8080. Also tried with other ports as well.

After saving the settings, when I am opening the picolog recorder and selecting PT-104 (Ethernet), it is not detecting the unit. I even tried punching the IP address and port in the bottom of the same screen, but to no avail.

I have modified the IP address of my Lan port to the same as PT-104 IP address.

Thanks!

Juned
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Sun Mar 31, 2013 7:54 am

Hi MArtyn,

I am unable to connect PT-104 using Ethernet (cross over cable) to my laptop.

What could be the problem?

A urgent help will be appreciated.

Thanks!
Juned
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby Martyn » Mon Apr 01, 2013 7:22 am

Can you open a CommandPrompt window and ping the IP address you have assigned to the PT104

ping 192.168.1.70

and post back the results.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Thu Apr 04, 2013 12:31 pm

Hi Martyn,

PLease find the ping sreen shot.

Also attached is the error that I am getting when using pico log with ethernet.

Thanks!

Juned
Attachments
Error Ehternet.jpg
Ethernet error in picolog
ping.jpg
Ping
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby Martyn » Thu Apr 04, 2013 12:55 pm

Have you got the USB port plugged in on the device to provide it with power ?

If yes then check your ethernet cables, and the ethernet settings you have applied to the unit using the ethernet settings utility program.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Thu Apr 04, 2013 1:56 pm

Martyn,

Yes, I have kept the USB plugged in.

Still getting this error.

Juned
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby Martyn » Thu Apr 04, 2013 2:10 pm

Then re run the EthernetSettings utility and reset the ip address (192.168.1.70) and port (6570), not 8080 which is a second http port, and try pinging again.

If it still doesn't respond to ping type
Code: Select all
route print

and
Code: Select all
ipconfig /all

and post the responses to these
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Thu Apr 04, 2013 2:31 pm

No it is still not responding.

Please see the result in attached file.

Juned
Attachments
Ethernet settings details.txt
Ping results
(11.31 KiB) Downloaded 204 times
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am

Re: Using PT-104 on multiple laptop at the same time

Postby Martyn » Thu Apr 04, 2013 2:46 pm

There is no ethernet address on your pc for 192.168.1.x which can talk to a PT104 configured as 192.168.1.70 as the ethernet adapter has defaulted to a Microsoft 169 address, 169.254.74.170(Preferred). This will have been issued when it failed to get a DHCP one.

Please check the network configuration for your ethernet card, turn off all other networks on the pC, including your wifi, and try again. Possibly even use 1:1 cables plugged into a hub.

Until you can ping the device you will not be able to talk to it.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2348
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Using PT-104 on multiple laptop at the same time

Postby junedfird » Thu Apr 04, 2013 3:45 pm

Hi Martyn,

I have been able to do this.

Now, I can run the picolog on two different PCs, one with USB and other with Ethernet.

I changed the IP address on my laptop to 192.168.1.1

Thanks!

Juned
junedfird
Newbie
 
Posts: 0
Joined: Thu Jan 03, 2013 11:40 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests