Test and Measurement Forum

Enviromon: Data Extraction troubleshooting

Come here to introduce yourself, who you are, and what you do

Enviromon: Data Extraction troubleshooting

Postby 1b3rt0 » Fri Feb 15, 2013 11:19 am

Hi Ziko, I'm speaking again about the EnviroMon software (we are going to become shortly your favourite italian experts).
Yesterday we installed EnviroMon by a customers, without problems at all, but EmDataGen, the software for the data extraction, doesn't works. It give me first the following generic error : 'can't initialize application' (or something like it). Following this, I remember that the software need the DotNet Framework and thereafter I installed the 4.0 version but still I get the following error: " .net framework initialization error, Unable to find a version of the runtime to run this application'.
Probably something has gone wrong with the installation of the DotNet framework, or...?
Then I tried to extract data with a batch (modeled upon your sample enviromon.bat) wich calls the 'emw32.exe' with the 'd' switch but also this fails (bach terminated without data extraction) . It is also with the emw32,exe needed a dotnet Framework?
The data extraction works instead perfectly from the menu Display/Graphic.

Thank you for your answer
Umberto
1b3rt0
Newbie
 
Posts: 0
Joined: Tue Nov 13, 2012 12:21 pm

Re: Enviromon: Data Extraction troubleshooting

Postby ziko » Wed Feb 27, 2013 12:05 pm

Hi Umberto,

Sorry for the delay, I have been on holiday for the last couple of weeks. This does look like a dotnet framework error, you only need .net framework 2. The -d is to download the data from the data logger, if you have EnviroMon already running it should not be used. Could you send me what you wrote in your batch file?

Regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: Enviromon: Data Extraction troubleshooting

Postby 1b3rt0 » Mon Mar 18, 2013 10:21 am

Hi Ziko,
thank you for your reply, I solved my issue downgrading the .net version (3.5 is still good, 4.0 don't).
But in your answer there is a thing I need to understand. You say that I shouldn't execute the following batch file

************
emw32 -d
set s=%date:~6,4%%date:~3,2%%date:~0,2%
emw32 -j"temperature.jpg",600,400,75 -rtoday@00:00-1month,today@00:00
emw32 -c"temperature.csv" -rtoday@00:00-1month,today@00:00
ftp -n -s:upload.ftp
copy temperature.jpg "C:\Pico Technology\EnviroMon\reports\jpg\%s%-temperature.jpg"
copy temperature.csv "C:\Pico Technology\EnviroMon\reports\csv\%s%-temperature.csv"
************

if there is already an instance of emw32.exe running.
I need the batch only to schedule data-extraction operation, but if you confirm then I should give a supplementary documentation to my customer to warn him to shut down the GUI before the batch starts
regards
umberto
1b3rt0
Newbie
 
Posts: 0
Joined: Tue Nov 13, 2012 12:21 pm

Re: Enviromon: Data Extraction troubleshooting

Postby ziko » Mon Mar 18, 2013 2:05 pm

Hi ,

If there already is an instance of EnviroMon running, then the line

emw32 -d

should be removed or you would exit the software and run the batch file, as you cannot have 2 sources downloading the same data.
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Re: Enviromon: Data Extraction troubleshooting

Postby 1b3rt0 » Tue Mar 19, 2013 9:08 am

Thank you Ziko,
it's a very important information, that I lost.
ciao
umberto
1b3rt0
Newbie
 
Posts: 0
Joined: Tue Nov 13, 2012 12:21 pm


Return to Introductions

Who is online

Users browsing this forum: No registered users and 2 guests